Ask Your Question
1

Not able to login to Instance console (Failed to connect to server (code: 1006) & Failed to login via SSH)

asked 2013-11-06 06:03:47 -0500

sasi gravatar image

updated 2013-11-06 06:12:45 -0500

Hi All,

I am new to openstack and started exploring openstack cinder by installing it on a single VM (virtualbox) following the install steps provided by devstack.

Here are the steps that are performed; created volume -> launch instance -> boot from image

After the above steps, i was able to see the snippet of instance boot (saying login as 'cirros' user. default password: 'cubswin:)'. use 'sudo' for root.).

But the problem is I was not able to view the console as it was showing an error "Failed to connect to server (code: 1006)". I tried to login to the instance from the VM using the IP shown in the console log as;

Starting dropbear sshd: generating rsa key... generating dsa key... OK
=== network info ===
if-info: lo,up,127.0.0.1,8,::1
if-info: eth0,up,10.0.2.18,24,fe80::f816:3eff:feba:cb45
ip-route:default via 10.0.2.2 dev eth0 
ip-route:10.0.2.0/24 dev eth0  src 10.0.2.18 
=== datasource: None None ===
=== cirros: current=0.3.1 uptime=98.83 ===
=== pinging gateway failed, debugging connection ===

############ debug start ##############

/etc/init.d/sshd start

Starting dropbear sshd: OK

ifconfig -a

eth0      Link encap:Ethernet  HWaddr FA:16:3E:BA:CB:45  
          inet addr:10.0.2.18  Bcast:10.0.2.255  Mask:255.255.255.0
          inet6 addr: fe80::f816:3eff:feba:cb45/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:30 errors:0 dropped:0 overruns:0 frame:0
          TX packets:70 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:7542 (7.3 KiB)  TX bytes:3728 (3.6 KiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:42 errors:0 dropped:0 overruns:0 frame:0
          TX packets:42 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:3731 (3.6 KiB)  TX bytes:3731 (3.6 KiB)

route -n

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         10.0.2.2        0.0.0.0         UG    0      0        0 eth0
10.0.2.0        0.0.0.0         255.255.255.0   U     0      0        0 eth0

ping -c 5 10.0.2.2

PING 10.0.2.2 (10.0.2.2): 56 data bytes

--- 10.0.2.2 ping statistics ---
5 packets transmitted, 0 packets received, 100% packet loss

And the nova list is shown as;

nova list

/usr/lib/python2.7/dist-packages/gobject/constants.py:24: Warning: g_boxed_type_register_static: assertion `g_type_from_name (name) == 0' failed
  import gobject._gobject
+--------------------------------------+------+--------+------------+-------------+--------------------------------+
| ID                                   | Name | Status | Task State | Power State | Networks                       |
+--------------------------------------+------+--------+------------+-------------+--------------------------------+
| 7920dec5-69e7-4b45-9baa-4c748797d112 | vol1 | ACTIVE | None       | Running     | private=10.0.0.2
+--------------------------------------+------+--------+------------+-------------+--------------------------------+

I have searched for links talking the same problem, but could not any solution.

Kindly guide / point me to appropriate manuals or solution links which helps ... (more)

edit retag flag offensive close merge delete

Comments

1

Please relook at MANY entries on this subject. I was able to combine information and work through this just a few weeks ago.

OldParrothead gravatar imageOldParrothead ( 2013-11-06 09:07:41 -0500 )edit

3 answers

Sort by ยป oldest newest most voted
1

answered 2013-11-11 23:14:40 -0500

DennyZhang gravatar image

Check the network in horizon, guess some ports of 10.0.2.0/24 netowk is down.

Looks like similar with mine: https://ask.openstack.org/en/question/6902/neutron-problem-about-ports-down/

edit flag offensive delete link more
1

answered 2013-11-26 00:42:01 -0500

lin-tan gravatar image

I have the same problem. I download another image and it works for me. http://cloud-images.ubuntu.com/precise/ I guess that's the problem of the cirros image. But in any case you need the keypair to ssh

edit flag offensive delete link more
1

answered 2013-11-26 01:50:35 -0500

sngirame gravatar image

Check if nova-novncproxy listening on port 6080 Check if iptables has exception added for port 6080

Refer this link for details http://openstack.redhat.com/forum/discussion/570/solvednot-able-to-see-console-of-instances#Item_8

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-11-06 06:03:47 -0500

Seen: 4,681 times

Last updated: Nov 26 '13