Ask Your Question
3

openstack-packstack requires python-docutils

asked 2015-05-20 00:28:44 -0500

nragha gravatar image

Hi Experts,

I am pretty new to installing stuff, and recently i am planning to install openstack on RHEL 7 VM.

But when i give the command sudo yum install -y openstack-packstack, i am getting the below error.

Error: Package: openstack-packstack-2015.1-0.1.dev1537.gba5183c.el7.noarch (openstack-kilo) Requires: python-docutils You could try using --skip-broken to work around the problem You could try running: rpm -Va --nofiles --nodigest

can anyone help on how to resolve this, from the above error, i might need to install python-docutils, but the http://rdoproject.org didnt have any instructions on how to get that.

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
2

answered 2015-11-20 02:58:19 -0500

theillien gravatar image

If you have the actual RHEL7 installation media then you are presumably registering with an RHN account. If you're doing that then, again, presumably you have sufficient entitlements for RHEL.

When you register you'll want to auto-attach your entitlements:

# subscription-manger register --auto-attach

If you are already registered but have not attached entitlements:

# subscription-manager attach --auto

Either way, once you have a registered RHEL7 instance with the proper RHEL entitlements attached simply enable the Optional and Extras repositories:

# subscription-manager repos --enable rhel-7-server-optional-rpms --enable rhel-7-server-extras-rpms

After doing this, the openstack-packstack installation should run cleanly.

edit flag offensive delete link more
1

answered 2015-05-21 10:23:52 -0500

jdexter gravatar image

I would make sure you have epel repo enabled. If you still can not install with that then it is possible to download the rpm from here http://rpm.pbone.net/index.php3/stat/...

edit flag offensive delete link more

Comments

Hi dexter,

thanks for your workaround, but still after getting python-docutils and the epel repo, i am still getting the error, and now i did it with any installing openstack-packstack --skip-broken, but now when i give the next command packstack --allinone, i am getting the packstack not found err

nragha gravatar imagenragha ( 2015-05-21 21:27:44 -0500 )edit

And this is what i get when i run the install openstack-packstack with skip broken. http://postimg.org/image/6k1pbr8np/

nragha gravatar imagenragha ( 2015-05-21 21:32:35 -0500 )edit

So what are the Repos you have enabled?

jdexter gravatar imagejdexter ( 2015-05-29 13:08:17 -0500 )edit

dexter, somehow i even installed the rpm u said about, but still when i install the openstack-packstack, i still get the python-docutils required error.

nragha gravatar imagenragha ( 2015-05-30 00:34:25 -0500 )edit

yum repolist enabled Loaded plugins: langpacks, product-id, subscription-manager repo id repo name status !openstack-kilo OpenStack Kilo Repository 706 !rhel-7-server-rpms/7Server/x86_64 Red Hat Enterprise Linu

nragha gravatar imagenragha ( 2015-05-30 00:41:49 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2015-05-20 00:28:44 -0500

Seen: 4,699 times

Last updated: Nov 20 '15