Ask Your Question
0

[Neutron] router can't ping external gateway

asked 2015-05-19 04:01:21 -0500

ichi-the-one gravatar image

updated 2015-06-18 14:00:03 -0500

rbowen gravatar image

Hey people, I have an issue with my networking. I connected my openstack to an external network I did all the changes required. But still my router can't reach the external gateway.

=====ifcfg-br-ex
DEVICE=br-ex
DEVICETYPE=ovs
TYPE=OVSBridge
BOOTPROTO=static
IPADDR=192.168.5.33
NETMASK=255.255.255.0
ONBOOT=yes
GATEWAY=192.168.5.1
DNS1=8.8.8.8
DNS2=192.168.5.1


====ifcfg-eth0
DEVICE=eth0
HWADDR=00:0c:29:a2:b1:b9
ONBOOT=yes
TYPE=OVSPort
NM_CONTROLLED=yes
DEVICETYPE=ovs
OVS_BRIDGE=br-ex

======[root@localhost ~(keystone_admin)]# ovs-vsctl show
19de58db-509d-4de8-bd88-9222019b13f1
    Bridge br-int
        fail_mode: secure
        Port "tap8652132e-b8"
            tag: 1
            Interface "tap8652132e-b8"
                type: internal
        Port br-int
            Interface br-int
                type: internal
        Port patch-tun
            Interface patch-tun
                type: patch
                options: {peer=patch-int}
    Bridge br-ex
        Port "qg-5f8ebe30-40"
            Interface "qg-5f8ebe30-40"
                type: internal
        Port "eth0"
            Interface "eth0"
        Port br-ex
            Interface br-ex
                type: internal
    Bridge br-tun
        Port "vxlan-c0a80520"
            Interface "vxlan-c0a80520"
                type: vxlan
                options: {df_default="true", in_key=flow, local_ip="192.168.5.33", out_key=flow, remote_ip="192.168.5.32"}
        Port br-tun
            Interface br-tun
                type: internal
        Port patch-int
            Interface patch-int
                type: patch
                options: {peer=patch-tun}
    ovs_version: "2.3.1"
=====[root@localhost ~(keystone_admin)]# ping 192.168.5.1
PING 192.168.5.1 (192.168.5.1) 56(84) bytes of data.
64 bytes from 192.168.5.1: icmp_seq=1 ttl=64 time=1.76 ms
64 bytes from 192.168.5.1: icmp_seq=2 ttl=64 time=1.88 ms
64 bytes from 192.168.5.1: icmp_seq=3 ttl=64 time=1.45 ms
^C
--- 192.168.5.1 ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2002ms
rtt min/avg/max/mdev = 1.452/1.699/1.880/0.187 ms
[root@localhost ~(keystone_admin)]#

======[root@localhost ~(keystone_admin)]# ip netns exec qrouter-85fa9459-503d-4996-86f3-6042604fed74 ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
14: qg-5f8ebe30-40: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN
    link/ether fa:16:3e:c2:1b:5e brd ff:ff:ff:ff:ff:ff
    inet 192.168.5.70/24 brd 192.168.5.255 scope global qg-5f8ebe30-40
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:fec2:1b5e/64 scope link
       valid_lft forever preferred_lft forever
[root@localhost ~(keystone_admin)]#

======[root@localhost ~(keystone_admin)]# ip r
default via 192.168.5.1 dev br-ex
default via 192.168.4.1 dev eth1
169.254.0.0/16 dev eth0  scope link  metric 1002
169.254.0.0/16 dev eth1  scope link  metric 1003
169.254.0.0/16 dev br-ex  scope link  metric 1005
192.168.4.0/24 dev eth1  proto kernel  scope link  src 192.168.4.14
192.168.5.0/24 dev br-ex  proto kernel  scope link  src 192.168.5.33
[root@localhost ~(keystone_admin)]#


======[root@localhost ~(keystone_admin)]# ip netns exec qrouter-85fa9459-503d-4996-86f3-6042604fed74 ip ...
(more)
edit retag flag offensive close merge delete

Comments

Please, post

systemctl status NetworkManager

on Network Node

dbaxps gravatar imagedbaxps ( 2015-06-18 14:25:33 -0500 )edit
1

qr-xxxxxxx is supposed to be attached to br-int. You have OVS misconfiguration.

dbaxps gravatar imagedbaxps ( 2015-06-18 14:33:09 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-10-20 01:44:31 -0500

I have same issue. My packstack juno is installed in virtualbox VM. My laptop's gateway is 192.168.1.1 (my DSL modem). From my VM, I can ping anywhere to the world. But from my neutron router namespace (ip netns exec <qrouter-xx...&gt; ping="" ...="" )="" i="" can="" ping="" the="" br-ex="" ip,="" but="" no="" further="" than="" my="" gateway.="" my="" ifcfg-br-ex="" and="" ifcfg-eth0="" is="" similar="" to="" above="" configs="" shown.="" <="" p="">

Some posts suggested making eth0 promiscuous but that didn't help either. In the virtualbox VM settings, the interface is bridged (and promiscous). NetworkManager is disabled. My ovs-vsctl shows (abbreviated):

*Bridge br-ex*
    Port "enp0s3"
    Port phy-br-ex ..  {peer=int-br-ex}
    Port br-ex
    Port "qg-b8a2a282-a6"

*Bridge br-int*
    fail_mode: secure
    Port "tap37fefe36-d8"
    Port "qr-c3a208b8-87"
    Port br-int
    Port "tap76af693e-cc"
    Port int-br-ex ... {peer=phy-br-ex}

So all configs look ok to me, but still cannot ping 192.168.1.1 (gateway) from router namespace. Have looked at so many posts but not a single one has been able to solve this problem. Is OpenStack fundamentally broken for installing in virtual environments ?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-05-19 04:01:21 -0500

Seen: 1,407 times

Last updated: Jun 18 '15