Ask Your Question
0

Problem to load consoles with Kilo [DevStack]

asked 2015-05-16 16:01:13 -0500

ralvarep gravatar image

Hi everyone!

I am using stable/kilo branch of devstack and when I create some instance I do not get access to the console of VM.

In Ubuntu 14.04 I have run:

  • git clone https://git.openstack.org/openstack-dev/devstack (https://git.openstack.org/openstack-d...)

  • git checkout stable/kilo

  • local.conf:

    [[local|localrc]]
    
    ADMIN_PASSWORD=password
    MYSQL_PASSWORD=$ADMIN_PASSWORD
    RABBIT_PASSWORD=$ADMIN_PASSWORD
    SERVICE_PASSWORD=$ADMIN_PASSWORD
    SERVICE_TOKEN=tokentoken
    
    disable_service n-net
    enable_service q-svc
    enable_service q-agt
    enable_service q-dhcp
    enable_service q-l3
    enable_service q-meta
    
  • And ./stack.sh

When stack.sh has finished, I can see the network topology of demo project correctly with public network and private network. Then, when I launch the instance, I can see that the status is active and with the logs that is running, but when I want to load the console I can't get it. http://imgspice.com/9npcg534jf2q/Captura_de_pantalla_de_2015-05-12_19:34:12.png.html (Image1)

Futrthermore, the network topology takes too long to load http://imgspice.com/evqfd0xkkez8/Captura_de_pantalla_de_2015-05-12_18:17:01.png.html (Image2)

I can check that the instances are running:

vnx@ctrlnet-cmp1:~/devstack$ virsh list
Id    Name                           State
3     instance-00000002              running
4     instance-00000004              running
5     instance-00000006              running

But, when I try to load the console of some instance I have the same problem:

vnx@ctrlnet-cmp1:~/devstack$ sudo virsh console 3
Connected to domain instance-00000002
Escape character is ^]
error: internal error: character device <null> is not using a PTY

Does anyone have the same problem?

Thanks in advance.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2015-05-18 00:20:22 -0500

dbaxps gravatar image

updated 2015-05-18 00:27:15 -0500

I believe you local.conf is missing :-

enable_service n-cauth

Just check is daemon /usr/local/bin/nova-consoleauth is running or no, if no

/usr/bin/local/nova-consoleauth  --config-file /etc/nova/nova.conf

View also :-
https://ask.openstack.org/en/question...

I installed working devstack instance via stable/kilo with local.conf

[[local|localrc]]
HOST_IP=192.168.1.51
ADMIN_PASSWORD=secret
DATABASE_PASSWORD=$ADMIN_PASSWORD
RABBIT_PASSWORD=$ADMIN_PASSWORD
SERVICE_PASSWORD=$ADMIN_PASSWORD
SERVICE_TOKEN=a682f596-76f3-11e3-b3b2-e716f9080d50

FLOATING_RANGE=192.168.12.0/24
FLAT_INTERFACE=eth0
Q_FLOATING_ALLOCATION_POOL=start=192.168.12.150,end=192.168.12.254
PUBLIC_NETWORK_GATEWAY=192.168.12.15

# Useful logging options for debugging:
DEST=/opt/stack
LOGFILE=$DEST/logs/stack.sh.log
SCREEN_LOGDIR=$DEST/logs/screen

# The default fixed range (10.0.0.0/24) conflicted with an address
# range I was using locally.
FIXED_RANGE=10.254.1.0/24
NETWORK_GATEWAY=10.254.1.1

# Services
disable_service n-net
enable_service n-cauth
enable_service q-svc
enable_service q-agt
enable_service q-dhcp
enable_service q-l3
enable_service q-meta
enable_service horizon
disable_service tempest
edit flag offensive delete link more

Comments

Thanks dbaxps, you're right. With kilo it is necessary to enable the service n-cauth.

ralvarep gravatar imageralvarep ( 2015-05-18 02:26:55 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-05-16 16:01:13 -0500

Seen: 1,795 times

Last updated: May 18 '15