Ask Your Question
2

when ever i create alarm is state is insufficient data

asked 2015-05-14 06:43:25 -0500

mohsinali gravatar image

updated 2015-06-04 04:45:47 -0500

uts9 gravatar image

here is the command i use to create alarm and alarm is not triggered nor the state is changed can any one help whats i am doing wrong

ceilometer alarm-threshold-create --name lowcpu --description "trigger if cpu util is < 10 for 2 min" --project-id 1eca34963a8e4063900378595f6119ff --user-id dfbd9f354f5b480683b3cc4c4b9eca6f --alarm-action 'log:///alarm.txt' --ok-action 'log:///alarm.txt' --insufficient-data-action 'log:///alarm.txt' --meter-name cpu-util --period 120 --evaluation-periods 1 --statistic avg --comparison-operator lt --threshold 10.0 --repeat-actions True

and

+---------------------------+---------------------------------------+
| Property                  | Value                                       |
+---------------------------+---------------------------------------+
| alarm_actions          | [u'log:///alarm.txt']                 |
| alarm_id                  | 88b8cb22-4d10-41f6-8329-2b5e0aedceff  |
| comparison_operator| lt                                    |
| description               | trigger if cpu util is < 10 for 2 min |
| enabled                   | True                                  |
| evaluation_periods   | 1                                     |
| exclude_outliers          | False                                 |
| insufficient_data_actions | [u'log:///alarm.txt']                 |
| meter_name                | cpu-util                              |
| name                      | lowcpu                                |
| ok_actions              | [u'log:///alarm.txt']                 |
| period                    | 2                                     |
| project_id              |                                       |
| query                     |                                       |
| repeat_actions       | True                                  |
| state                     | insufficient data                     |
| statistic                 | avg                                   |
| threshold               | 10.0                                  |
| type                      | threshold                             |
| user_id                  | dfbd9f354f5b480683b3cc4c4b9eca6f      |
+---------------------------+---------------------------------------+
edit retag flag offensive close merge delete

Comments

@mohsinali Where this alarm.txt file should be created....

neelabhsingh gravatar imageneelabhsingh ( 2015-06-05 07:17:54 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
1

answered 2015-06-04 01:41:01 -0500

Alarm take some time to get required stats and than gets in normal/OK state. Wait for some time and than check back. Also look at /etc/ceilometer/pipeline.yaml and check the reporting time for respective meters.

edit flag offensive delete link more

Comments

1

In my experience, you need to set the reporting times in "/etc/ceilometer/pipeline.yaml" to be less than the period when you create the alarms.

~RP

rpga95 gravatar imagerpga95 ( 2015-07-28 12:59:14 -0500 )edit
0

answered 2015-06-02 08:53:39 -0500

yprokule gravatar image

If the question still valid - do you have a meter 'cpu-util' or 'cpu_util' ?

edit flag offensive delete link more

Comments

It is cpu_util

sanjana gravatar imagesanjana ( 2015-08-24 05:06:39 -0500 )edit

Can U try recreate alarm with 'cpu_util' meter instead of 'cpu-util'? Also, log action for 'ok|alarm|insufficient-data'-action will simply log info about state transition to the alarm-notifier.log and not to the file you specified.

yprokule gravatar imageyprokule ( 2015-08-25 07:22:58 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

3 followers

Stats

Asked: 2015-05-14 06:43:25 -0500

Seen: 3,137 times

Last updated: Jun 04 '15