Ask Your Question
1

error during chunked upload - can't create large glance images

asked 2015-05-13 15:30:46 -0500

serverascode gravatar image

updated 2015-05-15 08:50:04 -0500

Hi,

I have a problem in which I can't create instance snapshots or load images much larger than >300MB into glance which is backed by swift. Does anyone have any thoughts on this issue? We're using ssl and haproxy to provide ssl for swift and glance. I'm guessing the reset connection is not normal?

2015-05-13 14:17:53.237 5649 DEBUG glance_store._drivers.swift.store [18c390a4-ea7b-41c2-b91d-1ad394ab48c8 4c7a4516336044709460c0fa01de93b3 676c35d893ba41e5b8009dccf2d44ae1 - - -] Wrote chunk da02e51f-9842-45f0-bdc6-dd17f2afef06-00002 (2/105) of length 204800000 to Swift returning MD5 of content: 87742339a0759716e53926a5bd6ab641 add /usr/lib/python2.7/dist-packages/glance_store/_drivers/swift/store.py:529
2015-05-13 14:17:53.240 5649 INFO urllib3.connectionpool [18c390a4-ea7b-41c2-b91d-1ad394ab48c8 4c7a4516336044709460c0fa01de93b3 676c35d893ba41e5b8009dccf2d44ae1 - - -] Resetting dropped connection: s3-internal.sometestsite.net
2015-05-13 14:17:53.286 5649 ERROR glance_store._drivers.swift.store [18c390a4-ea7b-41c2-b91d-1ad394ab48c8 4c7a4516336044709460c0fa01de93b3 676c35d893ba41e5b8009dccf2d44ae1 - - -] Error during chunked upload to backend, deleting stale chunks

EDIT: Turns out the "resetting dropped connection" was caused by the "option httpclose" I had setup for swift-proxy in my haproxy config. After removing that, which I think drops back to the default "keep alive" mode in haproxy, that reset went away, and I was able to load larger images. Don't think glance was expecting that close.

edit retag flag offensive close merge delete

3 answers

Sort by » oldest newest most voted
0

answered 2016-06-02 00:40:38 -0500

聪明健康 gravatar image

updated 2016-06-02 00:42:16 -0500

I finally worked out the problem. I believe if you put the below settings in your devstack/local.conf

SWIFT_LOOPBACK_DISK_SIZE=100G

[[post-config|${SWIFT_CONF_DIR}/swift.conf]]

[swift-constraints]

max_file_size = 21474836482

reinstall openstack ./stack.sh ./unstack.sh, You should now be able to upload image under 20GB.

edit flag offensive delete link more
0

answered 2015-05-15 07:28:09 -0500

sunnyarora gravatar image

Can you Please check /etc/glance/glance-api.conf and /etc/glance/glance-cache.conf . As i understand you are facing this issue since By default, there is the maximum object size in Swift which can be for example 5GB i.e for image size of 5GB.

swift_store_large_object_size = 5120

This amount of data is written to a temporary disk buffer during the process of chunking the image file, and the default is 200MB. You may need to change the size of this setting of chunk size.

swift_store_large_object_chunk_size = 200

Then restart the glance services

service glance-api restart
service glance-registry restart

-In this case glance will slice all large snapshots to 200Mb files and Swift will successfully store it. -Default value doesn't work when user attempts to make a snapshots with size > 300 Mb. check here

edit flag offensive delete link more
0

answered 2016-02-22 06:32:38 -0500

聪明健康 gravatar image

I installed openstack using devstack, just wondering, how would I be able restart individual components in this case?

I don't find the glance-api or the glance-registry service

stack@mep-openstack1:/etc/glance$ sudo service --status-all [ + ] apache2 [ + ] apparmor [ ? ] cntlm [ ? ] console-setup [ + ] cron [ ? ] cryptdisks [ ? ] cryptdisks-early [ - ] dbus [ ? ] dns-clean [ + ] ebtables [ + ] friendly-recovery [ - ] grub-common [ ? ] irqbalance [ ? ] killprocs [ ? ] kmod [ + ] libvirt-bin [ + ] memcached [ ? ] mysql [ ? ] networking [ ? ] ondemand [ + ] open-iscsi [ ? ] pppd-dns [ - ] procps [ + ] rabbitmq-server [ ? ] rc.local [ + ] resolvconf [ + ] rsync [ + ] rsyslog [ ? ] screen-cleanup [ ? ] sendsigs [ - ] ssh [ - ] sudo [ ? ] sysfsutils [ + ] tgt [ + ] udev [ ? ] umountfs [ ? ] umountiscsi.sh [ ? ] umountnfs.sh [ ? ] umountroot [ - ] urandom [ - ] x11-common [ ? ] zfs-fuse

I also can't do ./unstack.sh, ./stack.sh, because if I do this, all my existing data will be wiped.

is there anyway to specify the swift_store_large_object_size in the local.conf, before the ./stack.sh installation.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-05-13 15:30:46 -0500

Seen: 2,114 times

Last updated: Jun 02 '16