Horizon dashboard not using local_settings [closed]

asked 2015-05-13 09:11:34 -0500

I'm very new to openstack, I've done a few test installs of icehouse, and now am trying juno on centos7.

I'm stopped at horizon setup, did what was in the doc (BTW cannot fully understand http://docs.openstack.org/juno/install-guide/install/yum/content/dashboard-system-requirements.html (System Requirements items))

And now am at verify operation stage and it's not working.

I get "Bad Request (400)" on the browser. I have modified /etc/openstack-dashboard/local_settings file (also tried to rename file with .py) and it's not loaded, as with "ALLOWED_HOSTS = ['*']" I still get that in my log files :

[Wed May 13 13:39:20.527210 2015] [:error] [pid 3772] Invalid HTTP_HOST header: 'ctrl'. You may need to add u'ctrl' to ALLOWED_HOSTS.

I verified the fact by modifying /usr/lib/python2.7/site-packages/django/http/request.py to display allowed_hosts:

[Wed May 13 13:39:20.527090 2015] [:error] [pid 3772] allowed_hosts: ['horizon.example.com', 'localhost']

and forcing it to ['*'] in that file makes the thing work, so why is my local_settings file not loaded ?

Can someone explain what I have missed ?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by vincent-legoll
close date 2015-07-15 02:20:50.241358

1 answer

Sort by ยป oldest newest most voted

answered 2015-05-28 08:02:27 -0500

Not an answer, but still...

It cured itself, not sure how. When I got back the morning after, launched the VMs, and BAM it was working. Sigh...

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2015-05-13 09:11:34 -0500

Seen: 1,837 times

Last updated: May 28 '15