Ask Your Question
0

Debugging noVNC Problem (Error 1006/111)

asked 2015-05-13 00:29:53 -0500

Shane gravatar image

I'm running a OpenStack Kilo on VMware VMs, everything goes well except online console. (I was following the Getting Started guide on OpenStack website)

The console shows Starting VNC handshake and then Failed to connect to server (code: 1006)

If any further information is needed, please comment! (included, nova.conf for both compute and controller, network information, and novncproxy log)

My network configuration:

* Controller (controller)
  > 2 NIC
    - Management
      * 172.16.135.131
    - External
      * 172.16.155.150
* Compute (compute1)
  > 2 NIC
    - Management
      * 172.16.135.133
    - Tunnel
      - 192.168.38.20
* Compute (compute2)
  > 2 NIC
    - Management
      * 172.16.135.137
    - Tunnel
      * 192.168.38.21

DNS Settings
openstack.local maps to 172.16.155.150
controller.openstack.local maps to 172.16.135.131

Here's my configuration file on the controller node:

> cat /etc/nova/nova.conf

[DEFAULT]
dhcpbridge_flagfile=/etc/nova/nova.conf
dhcpbridge=/usr/bin/nova-dhcpbridge
logdir=/var/log/nova
state_path=/var/lib/nova
lock_path=/var/lock/nova
force_dhcp_release=True
libvirt_use_virtio_for_bridges=True
verbose=True
ec2_private_dns_show_ip=True
api_paste_config=/etc/nova/api-paste.ini
enabled_apis=ec2,osapi_compute,metadata
rpc_backend = rabbit
auth_strategy = keystone
my_ip = 172.16.135.131
vncserver_listen = 172.16.135.131
vncserver_proxyclient_address = 172.16.135.131
network_api_class = nova.network.neutronv2.api.API
security_group_api = neutron
linuxnet_interface_driver = nova.network.linux_net.LinuxOVSInterfaceDriver
firewall_driver = nova.virt.firewall.NoopFirewallDriver

[database]
connection = mysql://nova:PASSWORD@controller.openstack.local/nova

[oslo_messaging_rabbit]
rabbit_host = controller.openstack.local
rabbit_userid = openstack
rabbit_password = PASSWORD

[oslo_concurrency]
lock_path = /var/lock/nova

[keystone_authtoken]
auth_uri = http://controller.openstack.local:5000
auth_url = http://controller.openstack.local:35357
auth_plugin = password
project_domain_id = default
user_domain_id = default
project_name = service
username = nova
password = PASSWORD

[glance]
host = controller.openstack.local

[neutron]
service_metadata_proxy = True
metadata_proxy_shared_secret = PASSWORD
url = http://controller.openstack.local:9696
auth_strategy = keystone
admin_auth_url = http://controller.openstack.local:35357/v2.0
admin_tenant_name = service
admin_username = neutron
admin_password = PASSWORD

And this is the configuration file on each of the compute node:

> cat /etc/nova/nova.conf

[DEFAULT]
dhcpbridge_flagfile=/etc/nova/nova.conf
dhcpbridge=/usr/bin/nova-dhcpbridge
logdir=/var/log/nova
state_path=/var/lib/nova
lock_path=/var/lock/nova
force_dhcp_release=True
libvirt_use_virtio_for_bridges=True
verbose=True
ec2_private_dns_show_ip=True
api_paste_config=/etc/nova/api-paste.ini
enabled_apis=ec2,osapi_compute,metadata

rpc_backend = rabbit

auth_strategy = keystone

my_ip = 172.16.135.137

vnc_enabled = True
vncserver_listen = 0.0.0.0
vncserver_proxyclient_address = 172.16.135.131
novncproxy_base_url = http://openstack.local:6080/vnc_auto.html

# verbose = True

network_api_class = nova.network.neutronv2.api.API
security_group_api = neutron
linuxnet_interface_driver = nova.network.linux_net.LinuxOVSInterfaceDriver
firewall_driver = nova.virt.firewall.NoopFirewallDriver

[oslo_messaging_rabbit]
rabbit_host = controller.openstack.local
rabbit_userid = openstack
rabbit_password = PASSWORD

[keystone_authtoken]
auth_uri = http://controller.openstack.local:5000
auth_url = http://controller.openstack.local:35357
auth_plugin = password
project_domain_id = default
user_domain_id = default
project_name = service
username = nova
password = PASSWORD

[glance]
host = controller.openstack.local

[oslo_concurrency]
lock_path = /var/lock/nova

[neutron]
url = http://controller.openstack.local:9696
auth_strategy = keystone
admin_auth_url = http://controller.openstack.local:35357/v2.0
admin_tenant_name = service
admin_username = neutron
admin_password = PASSWORD

Logs on controller

ConsoleAuth

> tail nova-consoleauth.log

2015-05-13 01:56:23.577 2000 INFO oslo_messaging._drivers.impl_rabbit [req-5e0aabb6-6582-47c0-9e06-5c19489412b5 84ef4aea3bea495bb37588a22d3f3684 e20b13df269146daaa14395b570f04f8 - - -] Connecting to AMQP server on controller.openstack.local:5672
2015-05-13 01:56:23.608 ...
(more)
edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
1

answered 2015-05-15 06:16:55 -0500

sunnyarora gravatar image

updated 2015-05-17 23:13:10 -0500

Can you please check changing these below entries on the /etc/nova/nova.conf of compute node. I believe 172.16.135.137 is the correct IP of compute node which you had mentioned.

Change

vncserver_listen = 0.0.0.0
vncserver_proxyclient_address = 172.16.135.131

to

vncserver_listen = 172.16.135.137
vncserver_proxyclient_address = 172.16.135.137

Then try restarting the novnc service on controller.

edit flag offensive delete link more
1

answered 2015-05-15 07:30:56 -0500

Tobias Urdin gravatar image

The vncserver_proxyclient_address configuration on the compute nodes should be the IP of the compute node. Also make sure on the computer trying to reach a instance over VNC console actually can contact the url specified in novncproxy_base_url

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-05-12 13:21:27 -0500

Seen: 2,792 times

Last updated: May 17 '15