Broker pipe error in neutron-server

asked 2015-05-10 23:57:15 -0500

askullmania gravatar image

Hello, I installed openstack-juno with with miratis fuel. when I try to launch a cluster it gets stuck in waiting stage and then goes to error. All the 3 instances of the cluster are in active state, But the cluster is in error state. Scanning through the logs I found a broke pipe error in the neutron-server logs.

oslo.messaging._drivers.impl_rabbit [-] Failed to publish message to topic 'reply_dad0203b66524b50b357f0a2d3a3fb71': [Errno 32] Broken pipe
    2010-01-24 20:56:40.528 15867 TRACE oslo.messaging._drivers.impl_rabbit Traceback (most recent call last):
    2010-01-24 20:56:40.528 15867 TRACE oslo.messaging._drivers.impl_rabbit   File "/usr/lib/python2.7/dist-packages/oslo/messaging/_drivers/impl_rabbit.py", line 681, in ensure
    2010-01-24 20:56:40.528 15867 TRACE oslo.messaging._drivers.impl_rabbit     return method()
    2010-01-24 20:56:40.528 15867 TRACE oslo.messaging._drivers.impl_rabbit   File "/usr/lib/python2.7/dist-packages/oslo/messaging/_drivers/impl_rabbit.py", line 784, in _publish
    2010-01-24 20:56:40.528 15867 TRACE oslo.messaging._drivers.impl_rabbit     publisher = cls(self.conf, self.channel, topic=topic, **kwargs
edit retag flag offensive close merge delete

Comments

Fuel 6.0? What cluster are you launching, a Sahara one? With which command?

Seems maybe the HA status is broken, what do crm status and pcs resource status say?

Fsoppelsa gravatar imageFsoppelsa ( 2015-05-12 11:15:57 -0500 )edit