Ask Your Question
0

Devstack without default networks,subnets & routers.

asked 2015-05-09 02:15:15 -0500

hardik italia gravatar image

Hi,

By default, devstack create networks, subnets as well as router for a tenant. are there any options avaibale to make sure, devstack does not create any of the above mentioned (Networks, subnets, routers).

Example: (I do not want devstack to pre-configure these networks,subnets & router)

$ neutron net-list +--------------------------------------+---------+----------------------------------------------------------+ | id | name | subnets | +--------------------------------------+---------+----------------------------------------------------------+ | 13d12786-48c0-4152-b0ec-9cd5fa1ea3ae | public | 3e090d20-5e55-4227-a8aa-61bcdd26376a 10.10.20.0/24 | | | | 617e2b5e-1c51-4fb9-8c73-a825d1e377f7 2001:db8::/64 | | 747809a1-89ba-4c61-8df6-8091be69db3a | private | 7fe344d1-dde5-40b7-8512-d6f88a659d09 fd68:8bcb:7305::/64 | | | | db678b9d-49ae-4a56-805b-14076251f95d 10.0.0.0/24 | +--------------------------------------+---------+----------------------------------------------------------+

$ neutron subnet-list +--------------------------------------+---------------------+---------------------+-------------------------------------------------------------------------------+ | id | name | cidr | allocation_pools | +--------------------------------------+---------------------+---------------------+-------------------------------------------------------------------------------+ | 3e090d20-5e55-4227-a8aa-61bcdd26376a | public-subnet | 10.10.20.0/24 | {"start": "10.10.20.101", "end": "10.10.20.199"} | | 617e2b5e-1c51-4fb9-8c73-a825d1e377f7 | ipv6-public-subnet | 2001:db8::/64 | {"start": "2001:db8::1", "end": "2001:db8::1"} | | | | | {"start": "2001:db8::3", "end": "2001:db8::ffff:ffff:ffff:fffe"} | | 7fe344d1-dde5-40b7-8512-d6f88a659d09 | ipv6-private-subnet | fd68:8bcb:7305::/64 | {"start": "fd68:8bcb:7305::2", "end": "fd68:8bcb:7305:0:ffff:ffff:ffff:fffe"} | | db678b9d-49ae-4a56-805b-14076251f95d | private-subnet | 10.0.0.0/24 | {"start": "10.0.0.2", "end": "10.0.0.254"} | +--------------------------------------+---------------------+---------------------+-------------------------------------------------------------------------------+

$ neutron router-list +--------------------------------------+---------+------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------+-------------+-------+ | id | name | external_gateway_info | distributed | ha | +--------------------------------------+---------+------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------+-------------+-------+ | ea9d3a3f-f41c-4800-a67d-ba81637c7d04 | router1 | {"network_id": "13d12786-48c0-4152-b0ec-9cd5fa1ea3ae", "enable_snat": true, "external_fixed_ips": [{"subnet_id": "3e090d20-5e55-4227-a8aa-61bcdd26376a", "ip_address": "10.10.20.101"}, {"subnet_id": "617e2b5e-1c51-4fb9-8c73-a825d1e377f7", "ip_address": "2001:db8::1"}]} | False | False | +--------------------------------------+---------+------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------+-------------+-------+

Thanks, Hardik Italia

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
2

answered 2015-05-09 22:37:26 -0500

hardik italia gravatar image

I found the solution.

Add following entry into local.conf

NEUTRON_CREATE_INITIAL_NETWORKS=False

edit flag offensive delete link more

Comments

For me, this is not getting created by default in one of my environments, but it is in another?? How do I get the default router1, and networks to be created? I tried setting that value to true, but nothing.

Thank you!

jsd79 gravatar imagejsd79 ( 2015-10-30 16:36:51 -0500 )edit

if you configure following parameters with proper values then it should create public,private networks & router. You do not need to specify NEUTRON_CREATE_INITIAL_NETWORKS in your local.conf then. FLOATING_RANGE FIXED_RANGE Q_FLOATING_ALLOCATION_POOL PUBLIC_NETWORK_GATEWAY NETWORK_GATEWAY

hardik italia gravatar imagehardik italia ( 2015-11-10 00:10:26 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-05-08 18:05:02 -0500

Seen: 289 times

Last updated: May 09 '15