Ask Your Question
0

error in creating the heat domain in Identity service

asked 2015-05-08 14:03:49 -0500

sri krishna gravatar image

when i try to setup the heat domain in keystone i am facing the below error.

root@controller:~# heat-keystone-setup-domain \
>   --stack-user-domain-name heat_user_domain \
>   --stack-domain-admin heat_domain_admin \
>   --stack-domain-admin-password 123456
heat-keystone-setup-domain: command not found

so i tried the same with heat-keystone-setup

root@controller:~# heat-keystone-setup --stack-user-domain-name heat_user_domain --stack-domain-admin heat_domain_admin --stack-domain-admin-password 123456
Authorization Failed: The resource could not be found. (HTTP 404)
[Call Trace]
/usr/bin/heat-keystone-setup:323:keystone_setup
/usr/bin/heat-keystone-setup:274:die_if_not_set
/usr/bin/heat-keystone-setup:84:die
[ERROR] /usr/bin/heat-keystone-setup:274 Fail to get TENANT_ID by 'token-get'
root@controller:~#

i am setting up the components in KILO release manually following the official documentation on ubuntu 14.04. how can i fix this? does the command option "heat-keystone-setup-domain" exist?

edit retag flag offensive close merge delete

Comments

I'm using ubuntu 14.04 and have the same issue. "heat-keystone-setup-domain" is missing. Can someone help?

gosharplite gravatar imagegosharplite ( 2015-05-25 22:29:06 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-05-26 15:37:34 -0500

Someone create a bug report about it.

I found a temporary solution. I wrote everything on a those place in comment (last comment). Link: https://bugs.launchpad.net/openstack-manuals/+bug/1453160 (https://bugs.launchpad.net/openstack-...)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2015-05-08 14:03:49 -0500

Seen: 698 times

Last updated: May 26 '15