Heat health monitor changes status of members to inactive.

asked 2015-05-08 11:05:44 -0500

JimZb gravatar image

Hello openstack community, I am using a heat template to create an autoscaling group with a load balancer. Currently scale up and down works but the haproxy health monitor associated changes the status of members to inactive therefore I am not getting any replies of the web servers. Each instance takes up to 5 minutes to boot and even though the health monitor delay and timeout have large values, they are still being set to inactive. This is the monitor in the yaml file:

monitor:
  type: OS::Neutron::HealthMonitor
    properties:
      type: HTTP
      delay: 60000
      max_retries: 10
      timeout: 60000
      http_method: GET
      url_path: /myapp

Is there any way to declare a dependency for the Health monitor to start checking after the initialization of at least one member of the auto scaling group? my auto scaling group gets the server template from a file:

resources:
  asg:
    type: OS::Heat::AutoScalingGroup
    properties:
      min_size: 1
      max_size: 2
      resource:
        type: lb_server.yaml
        properties:
          flavor: {get_param: flavor}
          image: {get_param: image}
          key_name: {get_param: key_name}
          network: {get_param: net}
          pool_id: {get_resource: pool}
          metadata: {"metering.stack": {get_param: "OS::stack_id"}}

I am currently looking at adding the depends_on parameter to the health monitor but I cant seem to make it work...

edit retag flag offensive close merge delete