Ask Your Question
1

Support for Intel Virtualization Technology (VT)

asked 2015-05-07 15:49:24 -0500

3j0s gravatar image

Greetings!

I have a problem when i try to build an instance (http://paste.openstack.org/show/215510), basicaly the error is "Error: No valid host was found. Exceeded max scheduling attempts 3 for instance.." the thing is that i was checking my nova and my controller and everything is seems ok.

But then i checked the hardware support and i realize that my controller support "intel (vmx)" and "amd (smv)" but the nova just support "intel" architecture.. So..

Could be that part of my problem?, that my nova does not have support for amd architecture?

Thx in advance

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2015-05-08 21:06:43 -0500

sunnyarora gravatar image

updated 2015-05-11 02:15:24 -0500

Probably that should not matter if your hardware is supported for virtualization. I am taking in account that you are using KVM as an hypervisor and you can go through some http://www.linux-kvm.org/page/FAQ#How_can_I_use_AMD-V_extension.3F (FAQs)

Can you check if all openstack services are running properly including the compute service on the node ?

openstack-service status

Please also check if you are trying to deploy the image, you are choosing proper flavor while deploying an instance. Also the instance you created with basic properties like size, hypervisor type etc and flavor should always be greater to the basic image settings.

edit flag offensive delete link more
0

answered 2015-05-09 15:54:57 -0500

sgordon gravatar image

updated 2015-05-09 15:55:28 -0500

To use KVM acceleration the hardware must support the VMX or SMV extensions. Where this is not the case you can change the virt_type to qemu in the Nova configuration and restart the compute agent (openstack-nova-compute or nova-compute on most distributions) to use QEMU emulation without KVM acceleration, but this will be noticeably slow.

To better debug your scheduling and confirm whether this is actually the issue though set debug=True in the /etc/nova/nova.conf file on the node running the scheduler, restart the scheduler service (openstack-nova-scheduler or nova-scheduler on most distributions), and try create the instance again. You will find output like this in the /var/log/nova/nova-scheduler.log log which will help you determine which filter eliminated the host(s):

[req-... None] Starting with 3 host(s)
[req-... None] Filter RetryFilter returned 3 host(s)
[req-... None] Filter AvailabilityZoneFilter returned 3 host(s) 
[req-... None] Filter RamFilter returned 2 host(s)
...

Note that the above output is somewhat truncated to save space.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-05-07 15:49:24 -0500

Seen: 173 times

Last updated: May 11 '15