Ask Your Question
0

neutron-openvswitch-agent is not running ... failed! Nothing the neutron-openvswitch-agent.log

asked 2015-05-07 08:32:38 -0600

StackLR gravatar image

Hi,

neutron-openvswitch-agent fails to start on my compute node. logs are not generated.

Below is my Nova.conf

[DEFAULT]
verbose = True
my_ip = 192.168.6.106
enabled_apis=ec2,osapi_compute,metadata
state_path=/var/lib/nova
lock_path=/var/lock/nova
rootwrap_config=/etc/nova/rootwrap.conf
auth_strategy=keystone
rabbit_host = controller
rabbit_userid = guest
rabbit_password = RABBIT_PASS
rpc_backend = rabbit
network_api_class = nova.network.neutronv2.api.API
security_group_api = neutron
linuxnet_interface_driver = nova.network.linux_net.LinuxOVSInterfaceDriver
firewall_driver = nova.virt.firewall.NoopFirewallDriver
default_floating_pool=ext-net
vnc_enabled=True
vncserver_listen=0.0.0.0
vnc_keymap="en-us"
vncserver_proxyclient_address = 192.168.6.106
novncproxy_base_url = http://controller:6080/vnc_auto.html
[cinder]
[libvirt]
[glance]
host=controller
[neutron]
url = http://controller:9696
admin_auth_url = http://controller:35357/v2.0
auth_strategy = keystone
admin_tenant_name = service
admin_username = neutron
admin_password = NEUTRON_PASS
metadata_proxy_shared_secret = METADATA_SECRET
service_metadata_proxy=True
[database]
connection = mysql://nova:NOVA_DBPASS@controller/nova
[conductor]
[cells]
[baremetal]
[vmware]
[spice]
html5proxy_base_url=http://127.0.0.1:6082/spice_auto.html
server_listen=0.0.0.0
server_proxyclient_address=$my_ip
enabled=true
[ssl]
[zookeeper]
[keystone_authtoken]
auth_uri = http://controller:5000/v2.0
identity_uri = http://controller:35357
admin_tenant_name = service
admin_user = nova
admin_password = NOVA_PASS

Below is my neutron.conf

 [DEFAULT]
verbose = True
lock_path = $state_path/lock
core_plugin = ml2
service_plugins = router
auth_strategy = keystone
allow_overlapping_ips = True
notify_nova_on_port_status_changes = True
notify_nova_on_port_data_changes = True
nova_url = http://controller:8774/v2
nova_region_name = regionOne
nova_admin_username = nova
nova_admin_tenant_id = 8693a3164c6e49b6a83754dee3d66eeb
nova_admin_password = NOVA_PASS
nova_admin_auth_url = http://controller:35357/v2.0
rabbit_host = controller
rabbit_userid = guest
rabbit_password = RABBIT_PASS
rpc_backend=rabbit
[matchmaker_redis]
[matchmaker_ring]
[quotas]
[agent]
root_helper = sudo neutron-rootwrap /etc/neutron/rootwrap.conf
[keystone_authtoken]
auth_uri = http://controller:5000/v2.0
identity_uri = http://controller:35357
admin_tenant_name = service
admin_user = neutron
admin_password = NEUTRON_PASS
[database]
connection = mysql://neutron_admin:NEUTRON_DBPASS@controller/neutron_admin
[service_providers]
service_provider=LOADBALANCER:Haproxy:neutron.services.loadbalancer.drivers.haproxy.plugin_driver.HaproxyOnHostPluginDriver:default
service_provider=VPN:openswan:neutron.services.vpn.service_drivers.ipsec.IPsecVPNDriver:default
edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2015-05-07 09:12:29 -0600

StackLR gravatar image

I have managed to fix the issue, there are extra space in neutron.conf were causing the issue. once the space were removed the service came up.

edit flag offensive delete link more
0

answered 2015-06-05 11:09:34 -0600

Aaron Wong gravatar image

ooops......I got the same issue with the agent not shown in the neutron agent-list command on controller, gotta checking each item in configure files

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-05-07 08:21:30 -0600

Seen: 1,189 times

Last updated: May 07 '15