Ask Your Question
0

Problem installing Glance

asked 2013-11-05 01:24:02 -0500

Colin gravatar image

I'm installing Havana on Ubuntu 13.10 and following the installation on the Openstack site. I am now at section 4 installing Glance but the glance-api service doesn't start.

In the log files I see the following message

CRITICAL glance [-] No module named v2

what is module v2 and what can I do to resolve this issue?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2013-11-05 02:36:16 -0500

dheeru gravatar image

Did you setup the prerequisite as in following link ? http://docs.openstack.org/havana/install-guide/install/apt/content/basics-packages.html

Did you install the glance as in the following link ? http://docs.openstack.org/havana/install-guide/install/apt/content/glance-install.html

4th step in the above link is glance-manage db_sync. All these steps passed ?

This message is just symptom some other issue. You can have detail look at the logs.

edit flag offensive delete link more

Comments

I stepped back and re-did some steps so I first uninstalled glance then followed the steps you mention - the error shows up straight after installation of glance. The registry seems to start OK but not glance itself :-( Any idea what the v2 dependency is?

Colin gravatar imageColin ( 2013-11-05 12:07:42 -0500 )edit

Do you still see the issue ? Did you resolve the issue ?

dheeru gravatar imagedheeru ( 2013-11-24 08:06:02 -0500 )edit

Do you still have the issue ? Is it resolved ? Do let me know if you need help. We can get into online chat and will help you.

dheeru gravatar imagedheeru ( 2013-12-02 23:44:34 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-11-05 01:24:02 -0500

Seen: 101 times

Last updated: Nov 05 '13