RDO All in one - Cannot associate floating ID to ports

asked 2015-05-06 15:34:33 -0500

OmegaHarvest gravatar image

Dear All

I'm currently in the process of attempting to setup RDO Juno on CentOS 7 in VMware Workstation as an all in one. I've read over many guides which all seem simple and easy to follow for an OpenStack beginner like me. This one has been especially helpful:

https://cunninghamshane.com/my-all-in-one-openstack-deployment-at-home/ (https://cunninghamshane.com/my-all-in...)

All goes well and I am able to spin up instances from the dashboard (accessed from another VM on the same LAN segment. However, the instances fail to get an IP. I'm assuming I have to associate a floating IP to the public network but when I select to do so I have no ports available.

I came across this bug and replaced the network.py file but still had no luck after a reboot:

https://review.openstack.org/#/c/132383/15/openstack_dashboard/api/neutron.py (https://review.openstack.org/#/c/1323...)

I tried manually adding a port association following this guide but get HTTP400 Bad Request on the final command. I checked for typos in IDs many times:

https://ask.openstack.org/en/question/54713/no-ports-available-when-trying-to-associate-a-floating-ip/ (https://ask.openstack.org/en/question...)

I'm confident the interfaces are set OK as I can access Horizon from the bridges interface on another VM on the same LAN segment.

I'm at a loss at this point on what it could be. The RDO installer is very simple and completes fine, I just cannot get access to the instances on the public network. From a console session to an instance I am unable to ping anywhere on public as I have no IP associated. I'm running instances in the admin project if this is relevant?

Thanks for any help. At this point I'm kind of desperate. Could this be an issue with running it all in VMware Workstation? People seem to have had luck with VirtualBox so hoped this would also be ok.

edit retag flag offensive close merge delete


You wrote : From a console session to an instance I am unable to ping anywhere on public as I have no IP associated
That's wrong outbound connectivity is not connect with presence of public IP. The last one is needed for inbound connectivity.

dbaxps gravatar imagedbaxps ( 2015-05-07 01:15:48 -0500 )edit

I would expect problems with Neutron L2 Layer. Please within from CirrOS VM:

dbaxps gravatar imagedbaxps ( 2015-05-07 01:19:03 -0500 )edit

Thank you for the clarification. I was expecting to see the public IP as well as the private IP in the instance. Now I know to associate the floating IP to the related port on the private network, everything is accessible at last!

Thanks again.

OmegaHarvest gravatar imageOmegaHarvest ( 2015-05-07 13:18:55 -0500 )edit

1 answer

Sort by ยป oldest newest most voted

answered 2015-05-07 00:15:03 -0500

dbaxps gravatar image

updated 2015-05-07 00:22:31 -0500

Use as comment due to known limitations

Try to reproduce via CLI as root

  $ . keystonerc_demo
  $ nova keypair-add oskeydev  > oskeydev.priv
  $ chmod 600 oskeydev.priv

  $ glance image-list
  | ID                                   | Name   | Disk Format | Container Format | Size    | Status |
  | fa7a83d1-3ddb-4c0e-9c07-839b6b00f8ca | cirros | qcow2       | bare             | 9761280 | active |

  $ nova boot --flavor 1 --key_name oskeydev --image \
    fa7a83d1-3ddb-4c0e-9c07-839b6b00f8ca CirrsOSDev

  $ nova list
  | ID                                   | Name        | Status | Task State | Power State | Networks     |
  | acfbd460-d8d7-4eba-962b-de6f2f50db12 | CirrOSDev | ACTIVE | None       | Running     | int= |

  If you can  start instance, what would return following command referencing server's ID ?

 $ neutron port-list --device-id acfbd460-d8d7-4eba-962b-de6f2f50db12
 | id                                   | name | mac_address       | fixed_ips                                                                       |
 | 4ecfe633-dbab-4660-a51c-78ea6dbcc149 |      | fa:16:3e:88:05:e0 | {"subnet_id": "04b95f13-cc77-4f9a-8206-7f6ed183461d", "ip_address": ""} |

Does it fail or no ? IF "YES" stop IF "NO" proceed :-

Create a floating IP

  $ neutron floatingip-create ext
  Created a new floatingip:
  | Field               | Value                                |
  | fixed_ip_address    |                                      |
  | floating_ip_address |                       |
  | floating_network_id | 12e4de23-34f8-4f9f-ba2b-810c36f3cc40 |
  | id                  | 5976f269-bca2-4c44-8860-7d493909568f |
  | port_id             |                                      |
  | router_id           |                                      |
  | tenant_id           | 2c845a6ad20e45ccb0b045cee27a9661     |

Associate floating IP with the port of the VM

  $ neutron floatingip-associate 5976f269-bca2-4c44-8860-7d493909568f 4ecfe633-dbab-4660-a51c-78ea6dbcc149
  Associated floatingip 5976f269-bca2-4c44-8860-7d493909568f

Show the floating IP

  $ neutron floatingip-show 5976f269-bca2-4c44-8860-7d493909568f
edit flag offensive delete link more


Many thanks, this solution also works if I associate the floating IP to the private port. A learning curve issue on my part. Thank you for your time.

OmegaHarvest gravatar imageOmegaHarvest ( 2015-05-07 13:20:43 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2015-05-06 15:34:33 -0500

Seen: 1,046 times

Last updated: May 07 '15