Ceilometer does not take alarm action continuously

asked 2015-05-06 06:33:50 -0600

OPSNB gravatar image

Hi there,

I am trying to test the autoscaling of openstack ,but I found that the alarm action has not been taken continuously if previous alarm state is "alarm" ,following is my configuration:

web_server_scaleup_policy:
type: OS::Heat::ScalingPolicy
properties:
   adjustment_type: change_in_capacity
   auto_scaling_group_id: {get_resource: web_server_group}
   scaling_adjustment: 1

 web_server_scaledown_policy:
 type: OS::Heat::ScalingPolicy
 properties:
     adjustment_type: change_in_capacity
     auto_scaling_group_id: {get_resource: web_server_group}
     scaling_adjustment: -1

cpu_alarm_high:
type: OS::Ceilometer::Alarm
properties:
  description: Scale-up if the average CPU >= 90% for 15 minutes
  meter_name: cpu_util
  statistic: avg
  period: 900
  evaluation_periods: 1
  threshold: 90
  alarm_actions:
    - {get_attr: [web_server_scaleup_policy, alarm_url]}
  matching_metadata: {'metadata.user_metadata.stack': {get_param: 'OS::stack_id'}}
  comparison_operator: ge

 cpu_alarm_low:
 type: OS::Ceilometer::Alarm
 properties:
    description: Scale-down if the average CPU < 90% for 15 minutes
    meter_name: cpu_util
    statistic: avg
    period: 900
    evaluation_periods: 1
    threshold: 90

Do you have any ideas to solve this issue? Thanks in advance!

edit retag flag offensive close merge delete