Ask Your Question
0

No valid host was found. Exceeded max scheduling attempts 3 for instance

asked 2015-05-05 06:14:03 -0500

Aman gravatar image

updated 2015-05-05 06:42:27 -0500

SGPJ gravatar image

I am trying to setup a multinode OpenStack. When I boot an instance it is successfully created but it is going in ERROR state. I have checked the logs in /var/log/nova/nova-scheduler.log and it gives an Operational error “database is locked”. Moreover when I check the database there are no tables getting created in the Nova database, while Neutron and others have there tables.

The logs are following :

2015-05-05 14:35:13.158 18551 TRACE nova.openstack.common.periodic_task OperationalError: (OperationalError) database is locked u'UPDATE reservations SET deleted_at=?, deleted=id, updated_at=updated_at WHERE reservations.deleted = ? AND reservations.expire < ?' ('2015-05-05 09:05:13.150105', 0, '2015-05-05 09:05:13.138314')
2015-05-05 14:35:13.158 18551 TRACE nova.openstack.common.periodic_task 
2015-05-05 14:37:47.972 18551 INFO oslo.messaging._drivers.impl_rabbit [-] Connecting to AMQP server on controller:5672
2015-05-05 14:37:47.991 18551 INFO oslo.messaging._drivers.impl_rabbit [-] Connected to AMQP server on controller:5672
2015-05-05 15:10:59.535 18551 INFO nova.openstack.common.service [-] Caught SIGTERM, exiting
2015-05-05 15:11:01.506 19260 AUDIT nova.service [-] Starting scheduler node (version 2014.2.2)
2015-05-05 15:11:03.691 19260 INFO oslo.messaging._drivers.impl_rabbit [req-7b53c22a-2161-4f9f-9942-c39ad5b35ca0 ] Connecting to AMQP server on controller:5672
2015-05-05 15:11:03.747 19260 INFO oslo.messaging._drivers.impl_rabbit [req-7b53c22a-2161-4f9f-9942-c39ad5b35ca0 ] Connected to AMQP server on controller:5672
2015-05-05 15:21:55.601 19260 INFO nova.openstack.common.service [-] Caught SIGTERM, exiting
2015-05-05 15:21:56.568 19542 AUDIT nova.service [-] Starting scheduler node (version 2014.2.2)
2015-05-05 15:21:57.504 19542 INFO oslo.messaging._drivers.impl_rabbit [req-ee9a2d39-678d-48c2-b490-2894cb6370b5 ] Connecting to AMQP server on controller:5672
2015-05-05 15:21:57.514 19542 INFO oslo.messaging._drivers.impl_rabbit [req-ee9a2d39-678d-48c2-b490-2894cb6370b5 ] Connected to AMQP server on controller:5672
2015-05-05 15:32:39.316 19542 INFO oslo.messaging._drivers.impl_rabbit [-] Connecting to AMQP server on controller:5672
2015-05-05 15:32:39.343 19542 INFO oslo.messaging._drivers.impl_rabbit [-] Connected to AMQP server on controller:5672
2015-05-05 15:38:21.280 19542 INFO nova.openstack.common.service [-] Caught SIGTERM, exiting
2015-05-05 15:38:22.434 19954 AUDIT nova.service [-] Starting scheduler node (version 2014.2.2)
2015-05-05 15:38:23.173 19954 INFO oslo.messaging._drivers.impl_rabbit [req-b65ec7c6-6bbd-4e13-9694-da927c9cf337 ] Connecting to AMQP server on controller:5672
2015-05-05 15:38:23.248 19954 INFO oslo.messaging._drivers.impl_rabbit [req-b65ec7c6-6bbd-4e13-9694-da927c9cf337 ] Connected to AMQP server on controller:5672
2015-05-05 15:39:46.468 19954 INFO oslo.messaging._drivers.impl_rabbit [-] Connecting to AMQP server on controller:5672
2015-05-05 15:39:46.484 19954 INFO oslo.messaging._drivers.impl_rabbit [-] Connected to AMQP server on controller:5672

The configuration for nova.conf is :

[DEFAULT]
dhcpbridge_flagfile=/etc/nova/nova.conf
dhcpbridge=/usr/bin/nova-dhcpbridge
logdir=/var/log/nova
state_path=/var/lib/nova
lock_path=/var/lock/nova
force_dhcp_release=True
libvirt_use_virtio_for_bridges=True
verbose=True
ec2_private_dns_show_ip=True
api_paste_config=/etc/nova/api-paste.ini
enabled_apis=ec2,osapi_compute,metadata
scheduler_default_filters=AllHostsFilter
verbose = True
connection = mysql://nova:NOVA_DBPASS@controller/nova
rpc_backend = rabbit
rabbit_host = controller
rabbit_password = RABBIT_PASS

auth_strategy = keystone

my_ip ...
(more)
edit retag flag offensive close merge delete

2 answers

Sort by » oldest newest most voted
0

answered 2015-05-05 07:04:23 -0500

  1. Check you could access nova DB with your nova credentials (nova:NOVA_DBPASS)
  2. Check you follow all the steps referenced in the installation guide. In particular, be sure you run command nova-manage db sync as referenced here [step 3]
edit flag offensive delete link more

Comments

Thanks it works....!

Aman gravatar imageAman ( 2015-05-05 23:13:08 -0500 )edit
0

answered 2015-05-07 15:08:55 -0500

3j0s gravatar image

2015-05-06 07:04:47.228 27758 WARNING nova.virt.libvirt.imagecache [-] Unknown base file: /var/lib/nova/instances/_base/46e103defd18fe7844a7e1269c3288b5af70b282 2015-05-06 07:45:44.250 27758 WARNING nova.virt.libvirt.imagecache [-] Unknown base file: /var/lib/nova/instances/_base/46e103defd18fe7844a7e1269c3288b5af70b282 2015-05-06 08:27:25.247 27758 WARNING nova.virt.libvirt.imagecache [-] Unknown base file: /var/lib/nova/instances/_base/46e103defd18fe7844a7e1269c3288b5af70b282 2015-05-06 09:08:18.226 27758 WARNING nova.virt.libvirt.imagecache [-] Unknown base file: /var/lib/nova/instances/_base/46e103defd18fe7844a7e1269c3288b5af70b282

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-05-05 06:14:03 -0500

Seen: 3,477 times

Last updated: May 05 '15