Ask Your Question
1

native ssl not working with devstack

asked 2015-05-05 01:38:51 -0500

Nicholas I gravatar image

updated 2015-05-05 04:42:19 -0500

SGPJ gravatar image

Hi,

I enabled USE_SSL=True in localrc file in devstack. When i run the ./stack.sh. I keep getting the below error message.

2015-05-05 06:30:57.650 | + [[ -n /opt/stack/logs/stack ]]
2015-05-05 06:30:57.650 | + echo 'logfile /opt/stack/logs/stack/q-svc.log.2015-05-04-231519'
2015-05-05 06:30:57.650 | + echo 'log on'
2015-05-05 06:30:57.650 | + screen -S stack -p q-svc -X stuff 'python /usr/local/bin/neutron-server --config-file /etc/neutron/neutron.conf --config-file /etc/neutron/plugins/ml2/ml2_conf.ini & echo $! >/opt/stack/status/stack/q-svc.pid; fg || echo "q-svc failed to start" | tee "/opt/sta'k/status/stack/q-svc.failure"
2015-05-05 06:30:57.676 | + echo 'Waiting for Neutron to start...'
2015-05-05 06:30:57.677 | Waiting for Neutron to start...
2015-05-05 06:30:57.677 | + is_ssl_enabled_service neutron
2015-05-05 06:30:57.677 | + local services=neutron
2015-05-05 06:30:57.677 | + local service=
2015-05-05 06:30:57.677 | + '[' True == False ']'
2015-05-05 06:30:57.677 | + for service in '${services}'
2015-05-05 06:30:57.677 | + [[ ,key,nova,cinder,glance,s-proxy,neutron,sahara, =~ ,neutron, ]]
2015-05-05 06:30:57.677 | + return 0
2015-05-05 06:30:57.677 | + ssl_ca=--ca-certificate=/opt/stack/data/ca-bundle.pem
2015-05-05 06:30:57.677 | + timeout 60 sh -c 'while ! wget --ca-certificate=/opt/stack/data/ca-bundle.pem --no-proxy -q -O- https://192.168.154.244:9696; do sleep 1; done'
2015-05-05 06:31:57.682 | + die 694 'Neutron did not start'
2015-05-05 06:31:57.682 | + local exitcode=0
2015-05-05 06:31:57.682 | [Call Trace]
2015-05-05 06:31:57.683 | ./stack.sh:1212:start_neutron_service_and_check
2015-05-05 06:31:57.683 | /home/nicholas/devstack/lib/neutron-legacy:694:die
2015-05-05 06:31:57.694 | [ERROR] /home/nicholas/devstack/lib/neutron-legacy:694 Neutron did not start

I tried running the command wget --ca-certificate=/opt/stack/data/ca-bundle.pem --no-proxy -q -O- https://192.168.154.244:9696 manually. It creates a ca-bundle.pem under /opt/stack/data/.

how can i solve it?

edit retag flag offensive close merge delete

Comments

1

Can you comment/remove q-svc in your localrc or local.conf?. This is to check whether https is getting enabled for other endpoints. Also check /opt/stack/logs/stack/q-svc.log.2015-05-04-231519

uts9 gravatar imageuts9 ( 2015-05-05 02:48:38 -0500 )edit

OK let me check

Nicholas I gravatar imageNicholas I ( 2015-05-05 03:22:49 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-05-05 04:02:59 -0500

Nicholas I gravatar image

updated 2015-05-05 04:04:08 -0500

When q-svc disabled in localrc, i am getting this below error.

2015-05-05 08:55:21.628 | ++ iniset /opt/stack/tempest/etc/tempest.conf service_available glance True
2015-05-05 08:55:21.654 | ++ for service in '${TEMPEST_SERVICES//,/ }'
2015-05-05 08:55:21.654 | ++ is_service_enabled nova
2015-05-05 08:55:21.657 | ++ return 0
2015-05-05 08:55:21.657 | ++ iniset /opt/stack/tempest/etc/tempest.conf service_available nova True
2015-05-05 08:55:21.682 | ++ for service in '${TEMPEST_SERVICES//,/ }'
2015-05-05 08:55:21.682 | ++ is_service_enabled cinder
2015-05-05 08:55:21.685 | ++ return 0
2015-05-05 08:55:21.685 | ++ iniset /opt/stack/tempest/etc/tempest.conf service_available cinder True
2015-05-05 08:55:21.706 | ++ for service in '${TEMPEST_SERVICES//,/ }'
2015-05-05 08:55:21.706 | ++ is_service_enabled swift
2015-05-05 08:55:21.714 | ++ return 1
2015-05-05 08:55:21.714 | ++ iniset /opt/stack/tempest/etc/tempest.conf service_available swift False
2015-05-05 08:55:21.735 | ++ for service in '${TEMPEST_SERVICES//,/ }'
2015-05-05 08:55:21.736 | ++ is_service_enabled ceilometer
2015-05-05 08:55:21.743 | ++ return 1
2015-05-05 08:55:21.743 | ++ iniset /opt/stack/tempest/etc/tempest.conf service_available ceilometer False
2015-05-05 08:55:21.756 | ++ for service in '${TEMPEST_SERVICES//,/ }'
2015-05-05 08:55:21.756 | ++ is_service_enabled heat
2015-05-05 08:55:21.769 | ++ return 1
2015-05-05 08:55:21.770 | ++ iniset /opt/stack/tempest/etc/tempest.conf service_available heat False
2015-05-05 08:55:21.787 | ++ for service in '${TEMPEST_SERVICES//,/ }'
2015-05-05 08:55:21.788 | ++ is_service_enabled neutron
2015-05-05 08:55:21.801 | ++ return 0
2015-05-05 08:55:21.801 | ++ iniset /opt/stack/tempest/etc/tempest.conf service_available neutron True
2015-05-05 08:55:21.815 | ++ is_ssl_enabled_service key
2015-05-05 08:55:21.815 | ++ local services=key
2015-05-05 08:55:21.816 | ++ local service=
2015-05-05 08:55:21.816 | ++ '[' True == False ']'
2015-05-05 08:55:21.816 | ++ for service in '${services}'
2015-05-05 08:55:21.816 | ++ [[ ,key,nova,cinder,glance,s-proxy,neutron,sahara, =~ ,key, ]]
2015-05-05 08:55:21.816 | ++ return 0
2015-05-05 08:55:21.816 | ++ iniset /etc/boto.cfg Boto ca_certificates_file /opt/stack/data/ca-bundle.pem
2015-05-05 08:55:21.831 | /home/nicholas/devstack/inc/ini-config: line 148: /etc/boto.cfg: Permission denied
2015-05-05 08:55:21.834 | Error on exit

Log:

tail /opt/stack/logs/stack/q-svc.log.2015-05-04-231519 

2015-05-04 23:31:51.070 INFO neutron.wsgi [-] (65366) accepted ('192.168.154.244', 47102)
2015-05-04 23:31:52.100 INFO neutron.wsgi [-] (65366) accepted ('192.168.154.244', 47103)
2015-05-04 23:31:53.131 INFO neutron.wsgi [-] (65366) accepted ('192.168.154.244', 47104)
2015-05-04 23:31:54.159 INFO neutron.wsgi [-] (65366) accepted ('192.168.154.244', 47105)
2015-05-04 23:31:55.201 INFO neutron.wsgi [-] (65366) accepted ('192.168.154.244', 47106)
2015-05-04 23:31:56.223 INFO neutron.wsgi [-] (65366) accepted ('192.168.154.244', 47107)
2015-05-04 23:31:57.242 INFO neutron.wsgi [-] (65366) accepted ('192.168.154.244', 47108)
Terminated
q-svc failed to start
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-05-05 01:38:51 -0500

Seen: 397 times

Last updated: May 05 '15