Ask Your Question
0

Enabling Neutron LBaaS with Kilo release

asked 2015-05-04 04:39:18 -0500

TV gravatar image

Hi all,

Had LBaaS working just fine with Juno but the same configuration doesn't seem to work on the new Kilo release on Ubuntu 14.04. I have the service plugin enabled:

[DEFAULT]
service_plugins =router,lbaas,metering,firewall

Also set device_driver to HAproxy and interface_driver to OVS in lbaas_agent.ini. This was sufficient for Juno, but with Kilo I get the following error from neutron-server:

No providers specified for 'LOADBALANCER' service, exiting

After doing some research I tried adding the following to /etc/neutron/neutron.conf:

[service_providers]
service_provider = LOADBALANCER:Haproxy:neutron_lbaas.services.loadbalancer.drivers.haproxy.plugin_driver.HaproxyOnHostPluginDriver:default

Though this removes the previous error, it results in the following new errors:

Reading service_providers from legacy location in neutron.conf, and ignoring values in neutron_*aas.conf files; this override will be going away soon.

Extension flavor not supported by any of loaded plugins Extension

port-security not supported by any of loaded plugins Extension

router-service-type not supported by any of loaded plugins Extension

vlan-transparent not supported by any of loaded plugins Extension

lbaas_agent_schedulerv2 not supported by any of loaded plugins Extension

lbaasv2 not supported by any of loaded plugins

So what is the proper way to configure LBaaS for Kilo? What am I missing here?

edit retag flag offensive close merge delete

Comments

Can you enable LBaaS in Kilo DevStack and try?

Configuration is ENABLED_SERVICES+=,q-lbaasv2

uts9 gravatar imageuts9 ( 2015-05-06 04:37:57 -0500 )edit

Some info here

uts9 gravatar imageuts9 ( 2015-05-06 04:58:42 -0500 )edit

Hi thanks but that's DevStack. I'm trying a regular deployment, so local.conf magic for me...

TV gravatar imageTV ( 2015-05-06 10:06:16 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2015-06-16 09:45:37 -0500

TV gravatar image

Problem is the lbaas package for Kilo. Bug and workaround can be found here: https://bugs.launchpad.net/ubuntu/+source/neutron-lbaas/+bug/1460228 (https://bugs.launchpad.net/ubuntu/+so...)

edit flag offensive delete link more

Comments

With this resolution is it working now ?

Prateek K gravatar imagePrateek K ( 2015-12-10 00:42:08 -0500 )edit

No I did not get it to work. Better luck with Liberty

TV gravatar imageTV ( 2015-12-10 02:56:46 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-05-04 04:38:47 -0500

Seen: 3,057 times

Last updated: Jun 16 '15