Ask Your Question
1

unable creating tenants keystone

asked 2013-11-04 01:47:08 -0500

rizka gravatar image

updated 2014-01-22 15:12:40 -0500

Evgeny gravatar image

Hi, I using openstack for ubuntu 12.04 in tutorial from https://cssoss.files.wordpress.com/2012/05/openstackbookv3-0_csscorp2.pdf when I creating tenants

keystone tenant-create --name admin

then

Expecting authentication method via either a service token, --token or env[SERVICE_TOKEN], or credentials, --os_username or env[OS_USERNAME].

what this mean ? what must I do to fix that ?

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
2

answered 2013-11-04 02:17:30 -0500

dheeru gravatar image

updated 2015-03-16 17:18:08 -0500

Did you set the SERVICE_TOKEN and SERVICE_ENDPOINT as defined the following link ?

  export OS_SERVICE_TOKEN=FCAF3E...<admin token="" generated="" by="" you="">
  export OS_SERVICE_ENDPOINT=http://controller:35357/v2.0

OR

    export SERVICE_TOKEN=FCAF3E...<admin token="" generated="" by="" you="">
    export SERVICE_ENDPOINT=http://controller:35357/v2.0

edit flag offensive delete link more

Comments

Hope this solved your issue. Please confirm. Do let me know if you need help.

dheeru gravatar imagedheeru ( 2013-11-05 03:53:08 -0500 )edit

hehehe... my wrong... I use wrong password to call mysql in keystone.conf so I can call mysql. When I use corect password in keystone.conf, everything solved...

rizka gravatar imagerizka ( 2013-11-08 00:13:43 -0500 )edit

that is really good. Request you to vote for the ans which I gave. There is uparrow and you put vote there for my ans.

dheeru gravatar imagedheeru ( 2013-11-08 02:54:25 -0500 )edit

I cannot solve this problem using your solution. Please help

mani619cash gravatar imagemani619cash ( 2014-03-31 05:21:22 -0500 )edit

I was able to get it to work by adding OS_SERVICE_TOKEN=${OS_SERVICE_TOKEN:-$SERVICE_TOKEN} to the openrc file

JoeW gravatar imageJoeW ( 2015-03-16 15:47:38 -0500 )edit
0

answered 2015-03-16 16:24:23 -0500

JoeW gravatar image

I was able to get it to work by adding OS_SERVICE_TOKEN=${OS_SERVICE_TOKEN:-$SERVICE_TOKEN} to the openrc file then source the file

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2013-11-04 01:47:08 -0500

Seen: 2,379 times

Last updated: Mar 16 '15