Ask Your Question
0

no valid host was found in multinode setup

asked 2015-05-01 02:19:42 -0500

Aman gravatar image

While creating a VM on a multinode OpenStack setup I am getting the following error:

"message": "No valid host was found. ", "code": 500, "details": " File \"/usr/lib/python2.7/dist-packages/nova/conductor/manager.py\", line 616, in build_instances

I have a multinode setup with a Compute node, Controller node and a network node. While running "nova service-list" command all my services are up and enabled. So I am not getting where are we going wrong in regards to this.

logs of nova.conductor.log

c20b69a2-0441-4a16-b14a-68f15b93b862 None] [instance: 2d631bcc-fdd1-4bba-ae46-9bc2dfff8963] Error from last host: compute (node compute): [u'Traceback (most recent call last):\n', u' File "/usr/lib/python2.7/dist-packages/nova/compute/manager.py", line 2036, in _do_build_and_run_instance\n filter_properties)\n', u' File "/usr/lib/python2.7/dist-packages/nova/compute/manager.py", line 2167, in _build_and_run_instance\n instance_uuid=instance.uuid, reason=six.text_type(e))\n', u'RescheduledException: Build of instance 2d631bcc-fdd1-4bba-ae46-9bc2dfff8963 was re-scheduled: Unexpected vif_type=binding_failed\n'] 2015-05-01 12:42:27.879 5183 WARNING nova.scheduler.driver [req-c20b69a2-0441-4a16-b14a-68f15b93b862 None] [instance: 2d631bcc-fdd1-4bba-ae46-9bc2dfff8963] NoValidHost exception with message: 'No valid host was found.' 2015-05-01 12:42:27.879 5183 WARNING nova.scheduler.driver [req-c20b69a2-0441-4a16-b14a-68f15b93b862 None] [instance: 2d631bcc-fdd1-4bba-ae46-9bc2dfff8963] Setting instance to ERROR state.

edit retag flag offensive close merge delete

Comments

Can you verify your filter parameter in your configuration file?

uts9 gravatar imageuts9 ( 2015-05-01 04:23:59 -0500 )edit

i did not get you. can you please explain, how to verify filter parameter.

Aman gravatar imageAman ( 2015-05-01 04:30:24 -0500 )edit

Filter values are defined using scheduler_default_filters parameter in nova.conf. Can you post the values?

uts9 gravatar imageuts9 ( 2015-05-01 04:57:23 -0500 )edit

i checked nova.conf file in both compute and controller node there we did not defined any scheduler_default_filters.

Aman gravatar imageAman ( 2015-05-01 05:11:10 -0500 )edit

I changed scheduler_default_filters in both controller or compute node and restarted the nova servicesand booted a vm but that vm went to scheduling state and not coming in running state. Is there specific node we have to change scheduler_default_filters value ?

Aman gravatar imageAman ( 2015-05-01 05:33:18 -0500 )edit

3 answers

Sort by ยป oldest newest most voted
0

answered 2015-05-01 05:22:02 -0500

uts9 gravatar image

Set scheduler_default_filters=AllHostsFilter in nova.conf and restart nova services.

edit flag offensive delete link more

Comments

I changed scheduler_default_filters in both controller or compute node and restarted the nova servicesand booted a vm but that vm went to scheduling state and not coming in running state.

Aman gravatar imageAman ( 2015-05-01 05:57:19 -0500 )edit
0

answered 2015-05-01 08:42:44 -0500

jdexter gravatar image

Do you have any metadata attached to your glance image?, From the looks of the error. the attempt to run a vm on the instance but fails, the reason for the failure is Unexpected vif_type=binding_failed It may be best to check nova network or neutron-ovs to see if there are errors with the port creation

edit flag offensive delete link more
0

answered 2015-05-04 02:14:36 -0500

sbiswas7 gravatar image

Assuming you are using neutron, do neutron agent-list on your controller node. This should list the neutron agent on your compute nodes. There can be a few possibilities after you have issued this command:

  1. Your neutron agent for the compute host is not listed - it means - your agent was never successful in registering itself to the neutron server on your controller node. check the server.log file under /var/log/neutron for more information on this along with the compute node logs under /var/log/neutron. Ensure that your compute and controller nodes don't have a time offset.

  2. You have a XXX marked against your neutron agent. This means - your AMQP is probably broken, this is unlikely because you seem to have registered your compute hosts just fine.

  3. You have neither of 1 or 2, in such a case, when you deploy the VM - check your neutron server.log file when you fire the deploy operation. One of the reasons for failure could be that your agent isn't using the right network types as expected by ML2. That is - if ML2 allows only vlan, vxlan but you are trying to register a gre based network - it would fail.

Hope this helps!

    3.
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-05-01 02:19:42 -0500

Seen: 1,574 times

Last updated: May 04 '15