Instance not accessible after trying the Single Flat Network config on Grizzly.

asked 2013-11-03 22:32:54 -0600

ammini gravatar image

Hi,

I installed an all-in-one grizzly installation on rhel6.4 and was following http://docs.openstack.org/network-admin/admin/content/use_cases_single_flat.html to get the networking done for the instance. The all-in-one installation is done on a vm which is on 192.168.0.0/24 network and the VM's eth0 interfaces is bridged to br-ex by OVS. The tenant network type is local and am just trying to give the instance an IP from the physical network I've (192.168.0.0/24). I created an external network and the subnet definition I gave as 192.168.0.0/24, with g/w as 192.168.0.254(my physical n/w gw ) and allocated 4 ips from 192.168.0.222 to 192.168.0.225. I've assigned the nameserver for instance to 192.168.0.254 as well while defining the subnet. I created a security group with two rules, allowing ICMP and ssh traffic to the instance from anywhere. After launching the instance, it gets 192.168.0.223 ip, but I can't ping/ssh to the instance.

Any pointers will be greatly appreciated.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2013-11-05 00:03:50 -0600

ammini gravatar image

Well I kind of fixed the issue using [1] and [2]

[1] http://openstack.redhat.com/forum/discussion/comment/1863 [2] http://openstack.redhat.com/Neutron_with_OVS_and_VLANs

But still the external network is consuming an ip address (192.168.0.1) from the provider network! Any one has info on how I'd avoid that?

Thanks

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-11-03 22:32:54 -0600

Seen: 130 times

Last updated: Nov 05 '13