Ask Your Question
0

Instances cant ping each other

asked 2015-04-29 22:22:18 -0500

beinghuman gravatar image

updated 2015-04-29 22:22:57 -0500

Hi Everyone,

i have setup 3 node(1 controller, 1 compute & 1 network) on Ubuntu 14.04 on Juno. I have followed the steps from the link below to setup the flat network and it works perfectly fine. http://docs.openstack.org/juno/instal...

Since we need VLAN's in our env to allow multiple subnets from the trunk link so i reinstalled everything and configured it to use VLAN's for tenant network. i am having some issues such as my instances cant ping each other. They are able to get IP via DHCP and i am also able to allocate floating IP's but i cant ping instances from the same subnet(VLAN) or any outside IP's. Not even the GW e.g. 192.168.1.1. Configuration looks ok to me but i may be wrong as i am not confident about this setup with VLAN's. I have attached details of the setup in the attached document for reference. I will really appreciaite if someone can help me with this issue.

C:\fakepath\Openstack Junu config-page-001.jpg

C:\fakepath\Openstack Junu config-page-002.jpg

[C:\fakepath\Openstack Junu config-page-003.jpg]

(/upfiles/1430364029683794.jpg)

(/upfiles/1430364022456557.jpg)

(/upfiles/1430364014265071.jpg)

(/upfiles/14303640044745197.jpg)

edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted
1

answered 2015-04-30 13:54:55 -0500

SGPJ gravatar image

Earlier I have faced this issue, I made sure the security groups had proper rules, as the setup was on nested VMs: allowed all traffic in base hypervisor and changed VLAN setup.

edit flag offensive delete link more

Comments

thanks i got it working by allowing all traffic from FW rules. although even after allowing all traffic i am not able to ping external network. I am noticing issue could be because of the VLAN mismatch. Can you tell me how will the network flow work in VLAN based network?

beinghuman gravatar imagebeinghuman ( 2015-04-30 18:44:30 -0500 )edit
1

answered 2015-04-30 00:12:38 -0500

dst_91 gravatar image

Make sure you have allowed all ICMP and TCP port access in default security group..For communication between the VMs, SSH port 22 should be allowed.

And if you are deploying OpenStack on Virtual Machines, make sure you have enabled promiscuous mode..

edit flag offensive delete link more
0

answered 2015-04-30 13:51:46 -0500

beinghuman gravatar image

updated 2015-04-30 13:52:16 -0500

Hi Thanks for your reply. I have checked the permissions in the default security group and i am allowing all ingress traffic(TCP, UDP & ICMP). What is bothering me more is why cant my VM(192.168.1.2) ping its gateway(192.168.1.1). Do you know if there is anything else i should be missing?

Env is deployed on VMware. When you say Promiscuous mode should enabled, are you referring on the vSwitch or on the Openstack nodes itself? Its enabled on the vSwitch but do i need to enable it on openstack nodes and or on the VM's as well? Appreciate your help with this.

edit flag offensive delete link more

Comments

Promiscuous mode should be enabled in VMware VMs.

SGPJ gravatar imageSGPJ ( 2015-04-30 13:56:28 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-04-29 22:22:18 -0500

Seen: 1,430 times

Last updated: Apr 30 '15