Ask Your Question
1

I'm trying to install Keystone on RHEL 7, but it isn't working.

asked 2015-04-29 00:05:36 -0500

anonymous user

Anonymous

updated 2015-04-29 00:19:29 -0500

I am trying to install keystone on RHEL v. 7. I haven't done this before.

I run this:

yum install openstack-keystone python-keystoneclient

I see this at the end:

--> Finished Dependency Resolution Error: Package: python-pycadf-0.6.0-2.el7.centos.noarch (openstack-juno) Requires: python-webob >= 1.2.3 Error: Package: python-eventlet-0.15.2-1.el7.noarch (epel) Requires: python-greenlet Error: Package: python-keystone-2014.2.2-1.el7.noarch (openstack-juno) Requires: python-webob >= 1.2.3 Error: Package: python-keystonemiddleware-1.2.0-1.el7.centos.noarch (openstack-juno) Requires: python-webob Error: Package: 1:python-keystoneclient-0.11.1-1.el7.centos.noarch (openstack-juno) Requires: python-webob You could try using --skip-broken to work around the problem You could try running: rpm -Va --nofiles --nodigest

But webob is installed with the correct version:

pip show webob

Name: WebOb Version: 1.4.1 Location: /usr/lib/python2.7/site-packages/WebOb-1.4.1-py2.7.egg Requires:

The extra packages are already installed:

rpm -i epel-release-7-5.noarch.rpm package epel-release-7-5.noarch is already installed

It looks like the relevant extra packages are installed.

How to do install python-keystoneclient? There appear to be dependency resolution issues. But they don't see real because the extra packages are installed.

A similar RedHat "bug" (not a real bug) was opened: tinyurl [DOT] com/osp9o93 (you have to construct the HTTP link above because I cannot post links; but someone may be able to help me without proving the research)

It directs the user to go here: tinyurl [DOT] com/65s3xm6 (you have to construct the HTTP link above because I cannot post links; but someone may be able to help me without proving the research)

The version of webob I have installed (as displayed by the pip command results) is new enough. Is RHEL v.7 not an acceptable version to install keystone?

Is python-webob different from webob?

I just want to install keystone on RedHat Linux. I don't know why this is problematic.

edit retag flag offensive close merge delete

Comments

Try yum -y install python-webob and see what happens then.

dbaxps gravatar imagedbaxps ( 2015-04-29 01:07:04 -0500 )edit

yum -y install python-webob Loaded plugins: amazon-id, rhui-lb ... Nothing to do

Abtul gravatar imageAbtul ( 2015-05-04 01:13:57 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2015-04-29 08:00:43 -0500

Run "yum install python-webob" and rerun "yum install openstack-keystone python-keystoneclient"

edit flag offensive delete link more

Comments

yum install python-webob Loaded plugins: amazon-id, rhui-lb No package python-webob available. Error: Nothing to do

When I tried to install openstack-keystone and python-keystoneclient, I got the same problem.

pip show webob indicates it is installed. Is there a 32 bit version of webob?

Abtul gravatar imageAbtul ( 2015-05-04 01:17:39 -0500 )edit
0

answered 2015-05-04 02:40:01 -0500

dbaxps gravatar image
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-04-29 00:05:36 -0500

Seen: 1,800 times

Last updated: May 04 '15