Ask Your Question
1

"No valid host was found". when install HP Helion OpenStack® Community Virtual Installation

asked 2015-04-27 22:39:05 -0600

xiaoxiaoxiaoqiqiqi gravatar image

Hi ALL :

  I am trying to install HP Helion OpenStack® Community Virtual Installation,

my physical server is HP ProLiant DL160 G6. i user vmware esxi 5.1 create a vm that its system is ubuntu13.10 server amd64 bits.

the Hardware and software configuration for virtual installations has meet the requirements.

 I   run "HP_VM_MODE=y bash -x ~root/work/tripleo/tripleo-incubator/scripts/hp_ced_host_manager.sh --create-seed" 
    it is successful,but when i  perform  to " bash -x /root/tripleo/tripleo-incubator/scripts/hp_ced_installer.sh"
    it is run a long time.finally it throw an error 

    error info :
    essage": "No valid host was found. ", "code": 500, "details": " File \"/opt/stack/venvs/nova/local/lib/python2.7/site-packages/nova/conductor/manager.py\", line 609, in build_instances | 
    | | request_spec, filter_properties  
    {"message": "No valid host was found. ", "code": 500, "details": " File \"/opt/stack/venvs/nova/local/lib/python2.7/site-packages/nova/conductor/manager.py\", line 609, in build_instances | 
    | | request_spec, filter_properties) | 
    | | File \"/opt/stack/venvs/nova/local/lib/python2.7/site-packages/nova/scheduler/rpcapi.py\", line 107, in select_destinations | 
    | | request_spec=request_spec, filter_properties=filter_properties) | 
    | | File \"/opt/stack/venvs/nova/local/lib/python2.7/site-packages/oslo/messaging/rpc/client.py\", line 152, in call | 
    | | retry=self.retry) | 
    | | File \"/opt/stack/venvs/nova/local/lib/python2.7/site-packages/oslo/messaging/transport.py\", line 90, in _send | 
    | | timeout=timeout, retry=retry) | 
    | | File \"/opt/stack/venvs/nova/local/lib/python2.7/site-packages/oslo/messaging/_drivers/amqpdriver.py\", line 404, in send | 
    | | retry=retry) | 
    | | File \"/opt/stack/venvs/nova/local/lib/python2.7/site-packages/oslo/messaging/_drivers/amqpdriver.py\", line 395, in _send | 
    | | raise result | 
    | | ", "created": "2015-04-27T02:35:10Z"} | 
    | flavor | baremetal (4b93086d-fed5-4c89-bee7-bb8c0bc02d46) | 
    | hostId | 2000629cbf5dce4a2d412896d95e1f94878017ac230d0a2ba6d31211 | 
    | id | 131b17b3-0bdc-4d71-a1c7-a1416ba5d49e | 
    | image | overcloud-control (c11c8f88-6ab4-4d9a-8e78-e32ef2dbd823) | 
    | key_name | default | 
    | metadata | {"group": "controller"} | 
    | name | overcloud-controller1-ghv4xtcy3pqi | 
    | os-extended-volumes:volumes_attached | [] | 
    | status | ERROR | 
    | tenant_id | 2e8c733ab03a44e6a7d7008de8f56062 | 
    | updated | 2015-04-27T02:35:10Z | 
    | user_id | fadad1596f754a2abcb6328226ea7af2
    '''

I am not familiar with tripleo , I Have read the questions on "https://ask.openstack.org “ wtih HPHelion tag ,no found answer someone can help me Many Thanks.

edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted
0

answered 2015-04-30 16:10:57 -0600

Which Ubuntu 13.10 image did you install on that VM? Also do you meet the requirements, 64GB of RAM, at least 200GB of available disk space.

https://wiki.ubuntu.com/SaucySalamand...

I would reprovision the vm with more RAM and Disk, download Ubuntu 13.10 server edition and re-deploy if you haven't already.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-04-27 22:39:05 -0600

Seen: 326 times

Last updated: Apr 30 '15