when instance is rebooted instance interface on compute node deleted

asked 2015-04-27 15:03:48 -0500

bobyakov gravatar image

updated 2015-04-27 15:04:20 -0500

Hi,

I am running ubuntu 14 with Ice house. Having a problem where some instances not getting a tap interface set up on compute node. Weird thing is that same compute has other instances working fine and same network has other instances working fine. It seems that very few instances are having this issue where virtual interface on instance not configured to compute host bridge.

brctl show:

bridge name     bridge id               STP enabled     interfaces
qbre685fd6a-f2          8000.966150e86a53       no              qvbe685fd6a-f2

Tried adding interface with

 virsh attach-interface instance-000007b3 bridge qbre685fd6a-f2

Interface goes away when instance is rebooted to get new ip..

edit retag flag offensive close merge delete

Comments

I would run :-

neutron port-list --owner network:dhcp

then

neutron port-show port-id  ( for each port-id entry in list above)

to make sure of "Active" status.

dbaxps gravatar imagedbaxps ( 2015-04-27 23:52:26 -0500 )edit

Is that on neutron server or on controller?

bobyakov gravatar imagebobyakov ( 2015-04-28 06:34:56 -0500 )edit

Neutron server ( e.g. Network Node )

dbaxps gravatar imagedbaxps ( 2015-04-28 06:42:54 -0500 )edit

Just to confirm ran neutron port-list --device_owner network:dhcp to see all DHCP ports, then ran neutron port-show id for each DHCP port, they are all active. I don't believe it's the DHCP agent because other instances work on same network. I believe it is specific to virtual interface on instance.

bobyakov gravatar imagebobyakov ( 2015-04-28 08:28:24 -0500 )edit

So when I ran neutron port-show on Instance ID, it shows that it is unbound to binding:host_id, binding:vif_details, and binding:vif_type. I know which compute host its built on. How do I bound it?

bobyakov gravatar imagebobyakov ( 2015-04-28 08:32:48 -0500 )edit