Ask Your Question
0

Connection to neutron failed: Maximum attempts reached problem

asked 2015-04-27 02:12:27 -0500

Aman gravatar image

updated 2015-04-27 02:14:11 -0500

SGPJ gravatar image

In multi node installation after finalizing neutron installation on controller node:

i ran this command to Populate the database:

su -s /bin/sh -c "neutron-db-manage --config-file /etc/neutron/neutron.conf \
  --config-file /etc/neutron/plugins/ml2/ml2_conf.ini stamp head" neutron

After this command i started the neutron server and nova api and perform this command on controller node.

=> neutron ext-list
error: Connection to neutron failed: Maximum attempts reached problem

I am following this link for installing : link text

edit retag flag offensive close merge delete

Comments

What is in /var/log/neutron/server.log ? Is AMQP brocker running ( rabbitmq-server ) ? Status of port 5672 ?

dbaxps gravatar imagedbaxps ( 2015-04-27 02:22:18 -0500 )edit

Start all nova services, afterwards run neutron-db-manage. Anyway sequence of steps on controller should be the same as described in
https://fosskb.wordpress.com/2014/10/...

dbaxps gravatar imagedbaxps ( 2015-04-27 02:59:05 -0500 )edit

i followed the steps given in openstack installation guide. Which are ;

Restart the Compute services:

service nova-api restart

service nova-scheduler restart

service nova-conductor restart

Restart the Networking service:

service neutron-server restart

Aman gravatar imageAman ( 2015-04-27 03:19:05 -0500 )edit

Wrong following manual.

1.apt-get install neutron-server neutron-plugin-ml2 python-neutronclient
2. Tune confifgs
3. neutron-db-manage
dbaxps gravatar imagedbaxps ( 2015-04-27 04:31:32 -0500 )edit

Your command 3 doesn't match manual , link you are referencing in your question.

dbaxps gravatar imagedbaxps ( 2015-04-27 04:33:32 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2015-04-27 04:39:20 -0500

dbaxps gravatar image

updated 2015-04-27 04:47:31 -0500

You don't follow http://docs.openstack.org/juno/instal...

1. It's not quite clear did you install required neutron packages or not 
2. It's not quite clear did you tune config files as required
3. I see mistake in neutron-db-manage command . It should end up with ".... upgrade juno" neutron

I also believe that nova services except compute should be up and running on Controller before you issue correct command invoking neutron-db-manage.

edit flag offensive delete link more
0

answered 2015-04-28 00:20:16 -0500

Aman gravatar image

updated 2015-04-28 01:14:03 -0500

sorry i used su -s /bin/sh -c "neutron-db-manage --config-file /etc/neutron/neutron.conf \ --config-file /etc/neutron/plugins/ml2/ml2_conf.ini upgrade juno" neutron command and i am getting the same error.

Please let me know the steps while using the MULTI-NODE SETUP

edit flag offensive delete link more

Comments

I still suggest you check just sequenceof your steps ( not neutron packages to be installed ) with https://fosskb.wordpress.com/2014/10/...

dbaxps gravatar imagedbaxps ( 2015-04-28 00:36:56 -0500 )edit

I stay away from any Ubuntu development for prod for many years. We work only with RH RDO releases. So , I am not Ubuntu Openstack expert. Try this :- https://github.com/vietstacker/openst...

dbaxps gravatar imagedbaxps ( 2015-04-28 01:37:31 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-04-27 02:12:27 -0500

Seen: 621 times

Last updated: Apr 28 '15