Ask Your Question
1

packstack --allinone stuck

asked 2015-04-26 20:03:07 -0500

ChrisGault gravatar image

Hi, I executed the command: packstack --allinone, and I get to a point where it's stuck at 'Testing if Puppet apply is finished'. This has been going on for hours. Please help me! (Running Fedora Server 21)

edit retag flag offensive close merge delete

Comments

Personally , I have got negative experience with F21 Server . "packstack --allinone" doesn't update firewalld rules properly. No metadata access as a final result. Try F21 Workstation . On workstation packstack works fine.

andrew.shvartz gravatar imageandrew.shvartz ( 2015-04-27 14:03:35 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-04-28 02:41:05 -0500

thewizardofOZ gravatar image

we need more details about the error but I had an error like:

ERROR : Error appeared during Puppet run: 172.17.150.100_keystone.pp
Error: /Stage[main]/Apache::Service/Service[httpd]: Failed to call refresh: Could not start Service[httpd]: Execution of '/sbin/service httpd start' returned 1: Redirecting to /bin/systemctl start  httpd.service
You will find full trace in log /var/tmp/packstack/20150321-101313-Y4ltZn/manifests/172.17.150.100_keystone.pp.log

you should add https services manually sudo yum httpd -y and add Include conf.modules.d/*.conf on /etc/httpd/conf/httpd.conf file

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-04-26 20:03:07 -0500

Seen: 6,235 times

Last updated: Apr 28 '15