Ask Your Question
0

Installation fails on CentOS 7

asked 2015-04-23 23:58:58 -0500

Johan Landerholm gravatar image

Hi, I'm kind of new to OpenStack and have decided to try it out using the RDO packstack installation tool.

I'm using the quickstart guide for packstack and it fails every time. First, I thought this was a locale thing, but I'm not so sure anymore. I use the en_US.UTF-8 locale for this latest try. I have tried to find other people with the same problem using google, but it seems I'm the only one with this problem. I've tried to install on a HP ProLiant DL380 with 20GB memory and 3Tb disk. I think the hardware should be good. This is the error from the "packstack --allinone" command:

Applying 10.0.0.42_keystone.pp
Applying 10.0.0.42_glance.pp
Applying 10.0.0.42_cinder.pp
10.0.0.42_keystone.pp:                            [ ERROR ]      
Applying Puppet manifests                         [ ERROR ]

ERROR : Error appeared during Puppet run: 10.0.0.42_keystone.pp
Error: invalid byte sequence in US-ASCII at /var/tmp/packstack/eb85ccfcf3c04ecc93e8cf7f65478b00/modules/keystone/manifests/wsgi/apache.pp:1 on node linux2.landerholm.net
You will find full trace in log /var/tmp/packstack/20150424-065027-DgWMEB/manifests/10.0.0.42_keystone.pp.log
Please check log file /var/tmp/packstack/20150424-065027-DgWMEB/openstack-setup.log for more information
Additional information:
 * Time synchronization installation was skipped. Please note that unsynchronized time on server instances might be problem for some OpenStack components.
 * File /root/keystonerc_admin has been created on OpenStack client host 10.0.0.42. To use the command line tools you need to source the file.
 * To access the OpenStack Dashboard browse to http://10.0.0.42/dashboard .
Please, find your login credentials stored in the keystonerc_admin in your home directory.
 * To use Nagios, browse to http://10.0.0.42/nagios username: nagiosadmin, password: <password>

And the log file is:

[root@linux2 ~]# more /var/tmp/packstack/20150424-065027-DgWMEB/manifests/10.0.0.42_keystone.pp.log
Error: NetworkManager is not running.
Warning: Scope(Class[Concat::Setup]): concat::setup is deprecated as a public API of the concat module and should no longer be directly 
included in the manifest.
Error: invalid byte sequence in US-ASCII at /var/tmp/packstack/eb85ccfcf3c04ecc93e8cf7f65478b00/modules/keystone/manifests/wsgi/apache.p
p:1 on node linux2
Wrapped exception:
invalid byte sequence in US-ASCII
Error: invalid byte sequence in US-ASCII at /var/tmp/packstack/eb85ccfcf3c04ecc93e8cf7f65478b00/modules/keystone/manifests/wsgi/apache.p
p:1 on node linux2

I'm using CentOS 7 fully updated with "yum -y update". Has anyone a clue where to start looking?

edit retag flag offensive close merge delete

Comments

View :- https://bugzilla.redhat.com/show_bug....
Seems strange
I would try unset locale at all.

dbaxps gravatar imagedbaxps ( 2015-04-24 13:05:12 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-04-24 18:49:39 -0500

jdexter gravatar image

Runpackstack --debug --allinone, this will log all commands being processed by packestack, and will allow you to see the exect error that is being generated and what command is being called to create the error.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-04-23 23:57:39 -0500

Seen: 1,022 times

Last updated: Apr 24 '15