Ask Your Question
0

flat_interface public_interface on same ethernet

asked 2015-04-21 10:02:30 -0500

uptime365 gravatar image

updated 2015-04-21 10:15:03 -0500

Hi all,

I'm following the centos7 juno setup from official docs, nova-networing two node setup

I have controller node with eth0 -> Management interface configured with ip 10.0.0.11 compute1 node with eth0 -> Management interface configured with ip 10.0.0.31 compute node with eth1 -> which doesn't have a ip configured as suggested, this interface is connected to external network

Setup worked fine and I was able to create a instance. But I'm not able to access the instances from external network , I'm only able to access them from the compute node ( where I have nova-network also )

On the nova-network setup it is suggested to give the flat_interface and public_interface the same interface name

flat_interface = INTERFACE_NAME
public_interface = INTERFACE_NAME

Replace INTERFACE_NAME with the actual interface name for the external network. For example, eth1 or ens224.

I have assigned eth1 to both variables . This is how the interface configuration looks now after assigning fixed and floating IP. Fixed ip range 192.168.1.145/29 , floating ip 192.168.1.202

2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
link/ether 74:d4:35:a1:1e:30 brd ff:ff:ff:ff:ff:ff
inet 10.0.0.31/24 brd 10.0.0.255 scope global enp1s0
   valid_lft forever preferred_lft forever
inet6 fe80::76d4:35ff:fea1:1e30/64 scope link 
   valid_lft forever preferred_lft forever
3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master br100 state UNKNOWN qlen 1000
link/ether 00:80:48:6e:f0:fd brd ff:ff:ff:ff:ff:ff
inet 192.168.1.202/32 scope global enp2s6
   valid_lft forever preferred_lft forever
inet6 fe80::280:48ff:fe6e:f0fd/64 scope link 
   valid_lft forever preferred_lft forever
4: br100: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP 
 link/ether 00:80:48:6e:f0:fd brd ff:ff:ff:ff:ff:ff
 inet 192.168.1.145/29 brd 192.168.1.151 scope global br100
   valid_lft forever preferred_lft forever
 inet6 fe80::280:48ff:fe6e:f0fd/64 scope link 
   valid_lft forever preferred_lft forever
5: vnet0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master br100 state UNKNOWN qlen 500
link/ether fe:16:3e:64:b7:e1 brd ff:ff:ff:ff:ff:ff
inet6 fe80::fc16:3eff:fe64:b7e1/64 scope link 
   valid_lft forever preferred_lft forever

Kindly suggest if I have done it right ? I read that the floating IP and fixed ip's are usually set using different interfaces. Let me know if setting both based on a single physical interface will work ?

Thanks

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-04-22 09:25:18 -0500

jdexter gravatar image

compute1 node with eth0 -> Management interface configured with ip 10.0.0.31 compute node with eth1 -> which doesn't have a ip configured as suggested, this interface is connected to external network

Typically speaking the flat interface that you created on eth1 with no IP would be on the controller or networking node (which ever node is running the l3 agent). It is at this point that when routers are created with the gateway on the external network, then would have external connectivity.

Please see the following doc on the rdoproject.org website that walks though the provider network process. Using provider networks

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-04-21 10:02:30 -0500

Seen: 858 times

Last updated: Apr 22 '15