Ask Your Question
0

Can't ping the tenant router Gateway

asked 2015-04-21 05:26:59 -0500

Martin872 gravatar image

Hello,

I try to Install OpenStack Juno (Ubuntu Server 64 Bit - 14.04 LTS). I followed the Instructions, and verified all previous steps. Now I am at Chapter 6. Now I try to "Verify the Connectivity". I should be able to ping the tenant router gateway from any other node including my Host PC. But I can't even ping the router gateway from the contoller or network node. I try to fix this problem since ... :-(

By the way.: I am able to ping the tenant router gateway from the network node with the following workaround:

ip netns exec qrouter-08dd4213-ce5a-4929-9a0b-1ff9035e1b1c ping 192.168.100.101

Here is my configuration... Hope somebody can help me...

BASIC Configuration:
--------------------------------------------------------------------------

Settings on my local PC - HOST System:
--------------------------------------

Windows 8
Norton InternetSecurity
IPv4: 192.168.178.38
Standardgateway: 192.168.178.1

V-Box - Global Settings:
------------------------

VirtualBox Host-Only Ethernet Adapter #2: 10.10.10.1
VirtualBox Host-Only Ethernet Adapter #3: 10.20.20.1
VirtualBox Host-Only Ethernet Adapter #4: 192.168.100.1

Compute-Node-V-Box-Settings:
----------------------------

Adapter 1: Paravirtualized Network - Promiscuous Mode: allow all (VirtualBox Host-Only Ethernet Adapter #2)
Adapter 2: Paravirtualized Network - Promiscuous Mode: allow all (VirtualBox Host-Only Ethernet Adapter #3)
Adapter 3: Paravirtualized Network - Promiscuous Mode: allow all (NAT)

Controller-Node-V-Box-Settings:
------------------------------

Adapter 1: Paravirtualized Network - Promiscuous Mode: allow all (VirtualBox Host-Only Ethernet Adapter #2)
Adapter 2: Paravirtualized Network - Promiscuous Mode: allow all (NAT)


Network-Node-V-Box-Settings:
------------------------------

Adapter 1: Paravirtualized Network - Promiscuous Mode: allow all (VirtualBox Host-Only Ethernet Adapter #2)
Adapter 2: Paravirtualized Network - Promiscuous Mode: allow all (VirtualBox Host-Only Ethernet Adapter #3)
Adapter 3: Paravirtualized Network - Promiscuous Mode: allow all (VirtualBox Host-Only Ethernet Adapter #4)
Adapter 4: Paravirtualized Network - Promiscuous Mode: allow all (NAT)


--------------------------------------------------------------------------
Controller-NODE: File: /etc/network/Interfaces
--------------------------------------------------------------------------

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet static
        address 10.10.10.10
        netmask 255.255.255.0


auto eth1
iface eth1 inet dhcp

--------------------------------------------------------------------------
Compute-NODE: File: /etc/network/Interfaces
--------------------------------------------------------------------------

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet static
        address 10.10.10.11
        netmask 255.255.255.0

auto eth1
iface eth1 inet static
        address 10.20.20.11
        netmask 255.255.255.0

auto eth2

--------------------------------------------------------------------------
NETWORK-NODE: File: /etc/network/Interfaces
--------------------------------------------------------------------------

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet static
        address 10.10.10.12
        netmask 255.255.255.0

auto eth1
iface eth1 inet static
        address 10.20.20.12
        netmask 255.255.255.0

auto eth2
iface eth2 inet manual
        up ifconfig $IFACE 0.0.0.0 up
        up ip link ...
(more)
edit retag flag offensive close merge delete

2 answers

Sort by » oldest newest most voted
0

answered 2015-04-25 06:19:38 -0500

Martin872 gravatar image

Anyone an idea? I try to solve this Issues for weeks... it's really important for me.

edit flag offensive delete link more

Comments

tag: 4095 from 'ovs-vsctl show' is not good. Reconfigure the network part and try again.

mickt gravatar imagemickt ( 2015-04-28 09:24:46 -0500 )edit
0

answered 2015-04-26 05:23:29 -0500

michal-gershenzon gravatar image

updated 2015-04-28 03:27:25 -0500

I think it might help if you use traceroute instead of ping, that will give you more information about the connection (to install on ubuntu: sudo apt-get install traceroute).

And in addition you can look at the route table (route -n), maybe you just need to add a static route.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2015-04-21 05:26:59 -0500

Seen: 699 times

Last updated: Apr 28 '15