Ask Your Question
0

Does Openstack support IPv6 + IPv4 setup on VM?

asked 2015-04-21 02:26:02 -0500

natsu gravatar image

updated 2015-04-23 01:08:43 -0500

Performed the following procedures.

  1. Created flat network "flat1"

  2. Created IPv6 subnet

    neutron subnet-create --name flat1-subnet1 \
           --ip_version 6 --ipv6-address-mode slaac \
           --ipv6-ra-mode slaac  flat1 2001:1:3238::/64
    
  3. Created IPv4 subnet

    flat1-subnet2

  4. Created router and added "flat1-subnet1" and "flat1-subnet2" as interface.
  5. Booted vm using --nic net-id=flat1 UUID

Result: On virsh console VM:

ifconfig

eth0

      Link encap:Ethernet  HWaddr FA:.........
      inet6 addr: fe80::f816:3eff:fee9:5b71/64 Scope:Link

IPv4 is not assigned. What could be wrong with this setup? Please advise.

edit retag flag offensive close merge delete

Comments

You can do a packet capture and check the dhcp lease being given. My guess is that the guest operating system is not requesting both a ipv6 and ipv4 dhcp lease.

jdexter gravatar imagejdexter ( 2015-04-23 07:43:34 -0500 )edit

hmm i did not consider this. thank you very much, jdexter!

natsu gravatar imagenatsu ( 2015-04-23 21:01:14 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
1

answered 2015-04-23 08:59:29 -0500

Robert Li gravatar image

Yes, we do support dual stack.

A few questions: -- does your setup work without adding the v6 subnet? -- is it a single node or multi node setup? For a single node, the v4 should work without concerning about your physical network setup. -- I saw that you are using SLAAC for v6. To make it work, check the following . Do you have radvd installed on your network node? . in your guest VM, do you have accept_ra turned on for your interface? The way to turn it on depends on your guest's operating system. On Ubuntu, check your config in /etc/network/interfaces

edit flag offensive delete link more

Comments

Thank you for the answer Mr. Li. Checked our system set-up 1. radvd is installed in network node. 2. did the following:
sysctl net.ipv6.conf.all.accept_ra=1 sysctl net.ipv6.conf.default.accept_ra=1 sysctl net.ipv6.conf.eth0.accept_ra=1 I bring down and up eht0 but stll no ipv4

natsu gravatar imagenatsu ( 2015-04-23 20:59:49 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2015-04-21 02:26:02 -0500

Seen: 1,306 times

Last updated: Apr 23 '15