Instance stuck in status "Migrating" after live migration

asked 2015-04-20 16:32:01 -0500

Neville gravatar image

updated 2015-04-21 02:55:08 -0500

SGPJ gravatar image

I'm trying to setup live migration and have this issue where the instance is successfully migrated to the new host but the status in Horizon stays stuck as "Migrating" forever. My setup consists of two nova-compute nodes using Ceph RBD backed volumes for the VM disks. I am also using CephFS as the shared storage for libvirt i.e. /var/lib/nova/instances. This is only a lab setup so for now I'm using TCP communications for libvirt without auth or encryption. I'll add that later once I've got the basics working. Anyone got any ideas where I should look? I can't find any errors in n-com, n-sched, n-api etc. Strangely my libvirt logs are always empty, not quite figured out how to resolve that yet either.

I've read that the way it's supposed to work is something polls the original host for the instance and when it disappears it triggers the post migration tasks like updating the status. Is this right? Since my instance is migrating successfully I'm not sure why that isn't happening.

TIA,

Nev

edit retag flag offensive close merge delete

Comments

Is your ceph cluster healthy (ceph -s), and does nova list show the instances stuck in migrating, are you able to 'nova reset-state'? Did the instances actually migrate? Are they visible via 'virsh list' from the original compute node? http://ceph.com/docs/master/rbd/rbd-o... <- this may help

omar-munoz gravatar imageomar-munoz ( 2015-04-23 16:27:44 -0500 )edit