Ask Your Question

Help Openstack allinone Icehouse instance is not connecting through externally

asked 2015-04-20 00:01:45 -0600

VickyBala91 gravatar image

updated 2015-04-20 02:18:37 -0600

SGPJ gravatar image

Hi All,

I have installed OpenStack RDO Icehouse release in all in one but instance is not able to connect from outside network. Could you please help fixing the issue and find the configuration details in below.

  1. CentOS 6.6 minimal VM running on Xenserver
  2. RDO Icehouse installed with disabled of SWIFT
  3. Configured br-ex with external ip
  4. Configured eth0 as provided in doc

cat /etc/sysconfig/network-scripts/ifcfg-eth0


 # cat /etc/sysconfig/network-scripts/ifcfg-br-ex

  Ping & SSG is not working in external NW
    # ping
    PING ( 56(84) bytes of data.
    --- ping statistics ---
    8 packets transmitted, 0 received, 100% packet loss, time 7375ms
    # ssh cirros@

# ip netns

PING & SSH is working with internal NW

# ip netns exec qrouter-691689dc-2b0b-4727-bf1b-1766e4fe60b9 ping
PING ( 56(84) bytes of data.
64 bytes from icmp_seq=1 ttl=64 time=13.3 ms
64 bytes from icmp_seq=2 ttl=64 time=1.75 ms

ovs-vsctl show

    Bridge br-tun
        Port br-tun
            Interface br-tun
                type: internal
        Port patch-int
            Interface patch-int
                type: patch
                options: {peer=patch-tun}
    Bridge br-int
        fail_mode: secure
        Port "tap3a3dfb70-7a"
            tag: 2
            Interface "tap3a3dfb70-7a"
                type: internal
        Port "qr-7cf48f7e-f9"
            tag: 2
            Interface "qr-7cf48f7e-f9"
                type: internal
        Port "qr-46ad506a-55"
            tag: 1
            Interface "qr-46ad506a-55"
                type: internal
        Port br-int
            Interface br-int
                type: internal
        Port patch-tun
            Interface patch-tun
                type: patch
                options: {peer=patch-int}
        Port "qvo40eb4810-f9"
            tag: 2
            Interface "qvo40eb4810-f9"
        Port "qvo08729356-d9"
            tag: 1
            Interface "qvo08729356-d9"
    Bridge br-ex
        Port br-ex
            Interface br-ex
                type: internal
        Port "eth0"
            Interface "eth0"
    ovs_version: "2.1.3"

OpenStack Status:


== Nova services ==
openstack-nova-api:                     active
openstack-nova-cert:                    active
openstack-nova-compute:                 active
openstack-nova-network:                 dead      (disabled on boot)
openstack-nova-scheduler:               active
openstack-nova-conductor:               active
== Glance services ==
openstack-glance-api:                   active
openstack-glance-registry:              active
== Keystone service ==
openstack-keystone:                     active
== Horizon service ==
openstack-dashboard:                    active
== neutron services ==
neutron-server:                         active
neutron-dhcp-agent:                     active
neutron-l3-agent:                       active
neutron-metadata-agent:                 active
neutron-lbaas-agent:                    inactive  (disabled on boot)
neutron-openvswitch-agent:              active
== Swift services ==
openstack-swift-proxy:                  active
openstack-swift-account:                active
openstack-swift-container:              active
openstack-swift-object:                 active
== Cinder services ==
openstack-cinder-api:                   active
openstack-cinder-scheduler:             active
openstack-cinder-volume:                active
openstack-cinder-backup:                active
== Ceilometer services ==
openstack-ceilometer-api:               active
openstack-ceilometer-central:           active
openstack-ceilometer-compute:           active
openstack-ceilometer-collector:         active
openstack-ceilometer-alarm-notifier:    active
openstack-ceilometer-alarm-evaluator:   active
== Support services ==
libvirtd:                               active
openvswitch:                            active
messagebus:                             active
tgtd:                                   active
rabbitmq-server:                        active
memcached:                              active
== Keystone users ==
Warning keystonerc not sourced

added following entries in /etc/neutron/plugin.ini however it doesn't have an [ovs] section, so added in [ml2_type_vlan]

network_vlan_ranges = physnet1 bridge_mappings = physnet1:br-ex

Could you please help fixing the issue.

edit retag flag offensive close merge delete


In Projects -> Network Topology (Horizon) Do you see any router?

uts9 gravatar imageuts9 ( 2015-04-20 04:56:51 -0600 )edit

Hi you tried the Security Group Option and adding need rules for ping and ssh .

rahulrajvn gravatar imagerahulrajvn ( 2015-04-20 13:16:01 -0600 )edit

Wondering if you'd had a chance to try the suggestions listed, and if you're still having this problem?

rbowen gravatar imagerbowen ( 2015-05-08 10:45:13 -0600 )edit

1 answer

Sort by ยป oldest newest most voted

answered 2015-05-21 00:07:10 -0600

VickyBala gravatar image

@uts9, I could see the router in Network Topology @rahurajvn, I had tried with security group by adding TCP Ping & SSH

even I tried upgrading with Kilo version with all in one but getting stuck same issue.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2015-04-20 00:01:45 -0600

Seen: 182 times

Last updated: Apr 20 '15