mongodb error in packsack

asked 2015-04-18 06:57:02 -0600

thebsdbox gravatar image

During the packstack --allinone i'm hitting an error during the application of the mongodb puppet manifest..                               [ DONE ]                          [ DONE ]                           [ DONE ]             
Applying                          [ ERROR ]        
Applying Puppet manifests                         [ ERROR ]

ERROR : Error appeared during Puppet run:
Error: Unable to connect to mongodb server! (
You will find full trace in log /var/tmp/packstack/20150417-164728-t1l2Dc/manifests/
Please check log file /var/tmp/packstack/20150417-164728-t1l2Dc/openstack-setup.log for more information
Additional information:
 * A new answerfile was created in: /root/packstack-answers-20150417-164728.txt
 * Time synchronization installation was skipped. Please note that unsynchronized time on server instances might be problem for some OpenStack components.
 * File /root/keystonerc_admin has been created on OpenStack client host To use the command line tools you need to source the file.
 * To access the OpenStack Dashboard browse to .
Please, find your login credentials stored in the keystonerc_admin in your home directory.
 * To use Nagios, browse to username: nagiosadmin, password: c7ed8201df044746

[root@openstack network-scripts]# tail /var/tmp/packstack/20150417-164728-t1l2Dc/openstack-setup.log
  File "/usr/lib/python2.7/site-packages/packstack/plugins/", line 126, in wait_for_puppet
  File "/usr/lib/python2.7/site-packages/packstack/modules/", line 107, in validate_logfile
    raise PuppetError(message)
PuppetError: Error appeared during Puppet run:
Error: Unable to connect to mongodb server! (
You will find full trace in log /var/tmp/packstack/20150417-164728-t1l2Dc/manifests/

2015-04-17 17:10:59::INFO::shell::94::root:: [] Executing script:

 rm -rf /var/tmp/packstack/5f7e9ac628d04f73bc41ead1afae55e2

    [root@openstack network-scripts]# netstat -an
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State      

tcp        0      0*               LISTEN

I've confirmed that mongodb is actually up and running and listening on the correct interfaces and ports..

edit retag flag offensive close merge delete


Cloud you please provide more logs from log /var/tmp/packstack/20150417-164728-t1l2Dc/manifests/

rahulrajvn gravatar imagerahulrajvn ( 2015-04-20 13:12:40 -0600 )edit

I encountered the same problem, I do not know where the problem lies. kilo

Earl gravatar imageEarl ( 2015-12-16 05:23:18 -0600 )edit

1 answer

Sort by ยป oldest newest most voted

answered 2015-04-20 11:13:19 -0600

thebsdbox gravatar image

/etc/mongod.conf needed editing to correct the binding to the correct interface.

edit flag offensive delete link more


Default port 27017,This is /etc/mongod.conf Not defined port

Earl gravatar imageEarl ( 2015-12-16 05:25:33 -0600 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2015-04-18 06:57:02 -0600

Seen: 254 times

Last updated: Apr 20 '15