Ask Your Question
0

KVM internal error. Suberror: 1

asked 2015-04-18 03:58:37 -0500

yangwolf gravatar image

updated 2015-04-18 04:00:42 -0500

dbaxps gravatar image

when create instance , happen follow erroor , Power State is Paused, Status is active , i check /var/log/libvirt/qemu/instance-00000006.log

LC_ALL=C PATH=/usr/local/sbin:/usr/local/bin:/usr/bin:/usr/sbin:/sbin:/bin QEMU_AUDIO_DRV=none /usr/bin/kvm-spice -name instance-000
00008 -S -machine pc-i440fx-trusty,accel=kvm,usb=off -cpu Opteron_G2,+osvw,+3dnowprefetch,+misalignsse,+sse4a,+abm,+cr8legacy,+extap
ic,+cmp_legacy,+3dnow,+3dnowext,+pdpe1gb,+fxsr_opt,+mmxext,+hypervisor,+popcnt,+x2apic,+ht,+vme -m 512 -realtime mlock=off -smp 1,so
ckets=1,cores=1,threads=1 -uuid 131b66dc-886e-4b41-972b-043c9ba1cc9b -smbios type=1,manufacturer=OpenStack Foundation,product=OpenSt
ack Nova,version=2014.1.3,serial=564d37e0-d90a-a270-ac93-106f9cf118e0,uuid=131b66dc-886e-4b41-972b-043c9ba1cc9b -no-user-config -nod
efaults -chardev socket,id=charmonitor,path=/var/lib/libvirt/qemu/instance-00000008.monitor,server,nowait -mon chardev=charmonitor,i
d=monitor,mode=control -rtc base=utc,driftfix=slew -global kvm-pit.lost_tick_policy=discard -no-hpet -no-shutdown -boot strict=on -d
evice piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -drive file=/var/lib/nova/instances/131b66dc-886e-4b41-972b-043c9ba1cc9b/disk,if=
none,id=drive-virtio-disk0,format=qcow2,cache=none -device virtio-blk-pci,scsi=off,bus=pci.0,addr=0x4,drive=drive-virtio-disk0,id=vi
rtio-disk0,bootindex=1 -netdev tap,fd=24,id=hostnet0,vhost=on,vhostfd=25 -device virtio-net-pci,netdev=hostnet0,id=net0,mac=fa:16:3e
:83:b5:a6,bus=pci.0,addr=0x3 -chardev file,id=charserial0,path=/var/lib/nova/instances/131b66dc-886e-4b41-972b-043c9ba1cc9b/console.
log -device isa-serial,chardev=charserial0,id=serial0 -chardev pty,id=charserial1 -device isa-serial,chardev=charserial1,id=serial1 
-device usb-tablet,id=input0 -vnc 192.168.2.118:0 -k en-us -device cirrus-vga,id=video0,bus=pci.0,addr=0x2 -device virtio-balloon-pc
i,id=balloon0,bus=pci.0,addr=0x5
char device redirected to /dev/pts/8 (label charserial1)
KVM internal error. Suberror: 1
emulation failure
EAX=00000000 EBX=40010000 ECX=00000030 EDX=00000cfd
ESI=00000000 EDI=00000000 EBP=00000000 ESP=00006fcc
EIP=3fedb16c EFL=00000002 [-------] CPL=0 II=0 A20=1 SMM=0 HLT=0
ES =0010 00000000 ffffffff 00409300 DPL=0 DS   [-WA]
CS =0008 00000000 ffffffff 00c09b00 DPL=0 CS32 [-RA]
SS =0010 00000000 ffffffff 00409200 DPL=0 DS   [-W-]
DS =0010 00000000 ffffffff 00409300 DPL=0 DS   [-WA]
FS =0010 00000000 ffffffff 00c09300 DPL=0 DS   [-WA]
GS =0010 00000000 ffffffff 00c09300 DPL=0 DS   [-WA]
LDT=0000 00000000 0000ffff 00008200 DPL=0 LDT
TR =0000 00000000 0000ffff 00008b00 DPL=0 TSS32-busy
GDT=     000f6688 00000037
IDT=     000f66c6 00000000
CR0=60000011 CR2=00000000 CR3=00000000 CR4=00000000
DR0=0000000000000000 DR1=0000000000000000 DR2=0000000000000000 DR3=0000000000000000 
DR6=00000000ffff0ff0 DR7=0000000000000400
EFER=0000000000000000
Code=00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 <00> 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
 00 00 00 00 00 00 00 00

pls help me , thanks

edit retag flag offensive close merge delete

Comments

Does it happen on bare metal or inside VM ?

dbaxps gravatar imagedbaxps ( 2015-04-18 04:09:56 -0500 )edit

Please, run

lsmod | grep kvm
dmesg|grep -i kvm
dbaxps gravatar imagedbaxps ( 2015-04-18 04:29:53 -0500 )edit

Which OS ?

Kernel version ?
Version of qemu-kvm ?
dbaxps gravatar imagedbaxps ( 2015-04-18 05:14:54 -0500 )edit

I found this bug, it seems similar to your problem... https://bugzilla.redhat.com/show_bug.cgi?id=1115208 (https://bugzilla.redhat.com/show_bug....)

tjiagoM gravatar imagetjiagoM ( 2015-04-18 18:59:26 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2015-04-21 00:05:05 -0500

dbaxps gravatar image

updated 2015-04-21 00:07:51 -0500

Using field as comment

 If
 # cat /sys/module/kvm_intel/parameters/nested 
  N
 You don't have nested virtualization enabled. Switch to virt_type=qemu.
 If 
 # cat /sys/module/kvm_intel/parameters/nested 
 Y

View http://www.server-world.info/en/note?...
View also https://bugzilla.redhat.com/show_bug....

I can't reproduce this anymore using kernel-3.17.8-300.fc21.x86_64 and qemu-kvm-2.1.2-7.fc21.x86_64
edit flag offensive delete link more
0

answered 2015-04-20 21:16:05 -0500

yangwolf gravatar image

updated 2015-04-20 21:23:26 -0500

inside VM ,`

lsmod | grep kvm :

kvm_amd 60026 0

kvm 455835 1 kvm_amd

root@ubuntu:/home# dmesg|grep -i kvm :

root@ubuntu:/home#

cat /proc/version :

Linux version 3.13.0-48-generic (buildd@orlo) (gcc version 4.8.2 (Ubuntu 4.8.2-19ubuntu1) ) #80-Ubuntu SMP Thu Mar 12 11:16:15 UTC 2015

Version of qemu-kvm is qemu-img version 2.0.0, Copyright (c) 2004-2008 Fabrice Bellard

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-04-18 03:58:37 -0500

Seen: 1,544 times

Last updated: Apr 21 '15