Ask Your Question
0

Can't access external network(internet) through management network on controller node

asked 2015-04-18 02:00:33 -0500

Gurmohit gravatar image

Ubuntu 14.04 on VMware

Controller node:

     $ ifconfig

      eth0     Link encap:Ethernet  HWaddr 00:0c:29:2c:eb:bb  
      inet addr:10.0.0.11  Bcast:10.0.0.255  Mask:255.255.255.0
      inet6 addr: fe80::20c:29ff:fe2c:ebbb/64 Scope:Link
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:170 errors:0 dropped:0 overruns:0 frame:0
      TX packets:209 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:22726 (22.7 KB)  TX bytes:27447 (27.4 KB)

      lo        Link encap:Local Loopback  
      inet addr:127.0.0.1  Mask:255.0.0.0
      inet6 addr: ::1/128 Scope:Host
      UP LOOPBACK RUNNING  MTU:65536  Metric:1
      RX packets:863 errors:0 dropped:0 overruns:0 frame:0
      TX packets:863 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:0 
      RX bytes:76654 (76.6 KB)  TX bytes:76654 (76.6 KB)

Network Node:

      $ ifconfig

      eth0      Link encap:Ethernet  HWaddr 00:0c:29:4a:75:db  
      inet addr:192.168.132.128  Bcast:192.168.132.255  Mask:255.255.255.0
      inet6 addr: fe80::20c:29ff:fe4a:75db/64 Scope:Link
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:810 errors:0 dropped:0 overruns:0 frame:0
      TX packets:695 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:410745 (410.7 KB)  TX bytes:113138 (113.1 KB)

      eth1      Link encap:Ethernet  HWaddr 00:0c:29:4a:75:e5  
      inet addr:10.0.0.21  Bcast:10.0.0.255  Mask:255.255.255.0
      inet6 addr: fe80::20c:29ff:fe4a:75e5/64 Scope:Link
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:229 errors:0 dropped:0 overruns:0 frame:0
      TX packets:165 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:33082 (33.0 KB)  TX bytes:22075 (22.0 KB)

      eth2      Link encap:Ethernet  HWaddr 00:0c:29:4a:75:ef  
      inet addr:10.0.1.21  Bcast:10.0.1.255  Mask:255.255.255.0
      inet6 addr: fe80::20c:29ff:fe4a:75ef/64 Scope:Link
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:62 errors:0 dropped:0 overruns:0 frame:0
      TX packets:128 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:8868 (8.8 KB)  TX bytes:18770 (18.7 KB)

       lo        Link encap:Local Loopback  
      inet addr:127.0.0.1  Mask:255.0.0.0
      inet6 addr: ::1/128 Scope:Host
      UP LOOPBACK RUNNING  MTU:65536  Metric:1
      RX packets:691 errors:0 dropped:0 overruns:0 frame:0
      TX packets:691 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:0 
      RX bytes:69958 (69.9 KB)  TX bytes:69958 (69.9 KB)

Interfaces

      $ cat /etc/network/interfaces 

      auto eth0
      iface eth0 inet manual
      up ip link set dev $IFACE up
      down ip link set dev ...
(more)
edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-04-29 06:16:46 -0500

capsali gravatar image

updated 2015-04-29 06:22:46 -0500

Well first of all i guess the cat /etc/network/interfaces is from the network node where eth0 is being assigned a dhcp ip. That's why you can ping the outside world. You should remove the gateway from eth1 on network node.

Second, do you have the gateway configured on the physical router for the 10.0.0.0/24 subnet? If not, then this is why there is no internet access on controller node. You should configure the gateway for this subnet, or share the internet connection from eth0 to eth1 on the network node and set the gateway of eth0 from the controller node to 10.0.0.21 .

I suggest you create the 10.0.0.0/24 subnet on the router and set the gateway, but remember to remove the gateway line from eth1(or even better, remove eth0 and leave eth1 with a gateway) on the network node, having two gateways on one system is bad if you do not specificaly assign the default route!

EDIT: I now see you are running in vmware. Two options come in mind:

  1. If u are using a physical router, then create a bridged connection in vmware and create a subnet on the router to match your management network.

  2. Create a private network in vmware without dhcp and a host adapter for it. From windows share your internet connection from the internet network adapter to the virtual adapter created by vmware on the host and then set the gateway for both controller and network node to match the ip of the host's virtual adapter!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-04-18 02:00:33 -0500

Seen: 331 times

Last updated: Apr 29 '15