Ask Your Question
0

Juno installation errors on RHEL 6.5 (subscribed)

asked 2015-04-17 04:41:33 -0500

enrollbusiness gravatar image

HI,

Im trying to install Juno on RHEL 6.5 following the guide. Is it supported on RHEL 6.5 ?

Errors which I see during installation:

#yum install mariadb mariadb-server MySQL-python

No package mariadb available. No package mariadb-server available.

# yum install yum-plugin-priorities

No package yum-plugin-priorities available.

# yum install http://dl.fedoraproject.org/pub/epel/...
# yum install http://rdo.fedorapeople.org/openstack...

3 and 4 worked fine. But when I see /etc/yum.repos.d/rdo-release.repo, baseurl is not correct. This url does not exists.

baseurl=http://repos.fedorapeople.org/repos/openstack/openstack-juno/epel-6/ [does not exists]

I modified it to :

baseurl=http://repos.fedorapeople.org/repos/openstack/openstack-juno/epel-7/

Than I ran:

# yum upgrade

It failed with a bunch of errors. Copying last lines.

Error: Package: evolution-data-server-2.32.3-21.el6.x86_64 (rhel-6-server-rpms) Requires: libdb-4.7.so()(64bit) Removing: db4-4.7.25-18.el6_4.x86_64 (@anaconda-RedHatEnterpriseLinux-201311111358.x86_64/6.5) libdb-4.7.so()(64bit) Obsoleted By: libdb4-4.8.30-13.el7.x86_64 (epel) Not found Available: db4-4.7.25-16.el6.x86_64 (rhel-6-server-rpms) libdb-4.7.so()(64bit) Available: db4-4.7.25-17.el6.x86_64 (rhel-6-server-rpms) libdb-4.7.so()(64bit) Error: Package: sendmail-8.14.4-8.el6.x86_64 (@rhel-6-server-rpms) Requires: libdb-4.7.so()(64bit) Removing: db4-4.7.25-18.el6_4.x86_64 (@anaconda-RedHatEnterpriseLinux-201311111358.x86_64/6.5) libdb-4.7.so()(64bit) Obsoleted By: libdb4-4.8.30-13.el7.x86_64 (epel) Not found Available: db4-4.7.25-16.el6.x86_64 (rhel-6-server-rpms) libdb-4.7.so()(64bit) Available: db4-4.7.25-17.el6.x86_64 (rhel-6-server-rpms) libdb-4.7.so()(64bit) Error: Package: pam-1.1.1-20.el6.i686 (rhel-6-server-rpms) Requires: libdb-4.7.so Removing: db4-4.7.25-18.el6_4.i686 (@rhel-6-server-rpms) libdb-4.7.so Obsoleted By: libdb4-4.8.30-13.el7.x86_64 (epel) Not found Available: http://buylikesandviews.com/ (Cheap Youtube Views) db4-4.7.25-16.el6.i686 (rhel-6-server-rpms) libdb-4.7.so Available: db4-4.7.25-17.el6.i686 (rhel-6-server-rpms) libdb-4.7.so You could try using --skip-broken to work around the problem ** Found 2 pre-existing rpmdb problem(s), 'yum check' output follows: kernel-2.6.32-431.el6.x86_64 has missing requires of dracut-kernel >= ('0', '002', '18.git413bcf78') kernel-2.6.32-431.29.2.el6.x86_64 has missing requires of dracut-kernel >= ('0', '002', '18.git413bcf78')

Do anyone know if Im missing something. Thanks.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2015-04-20 05:35:53 -0500

teju gravatar image

You need RHEL 7 to install JUNO....

http://docs.openstack.org/juno/instal...

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2015-04-17 04:41:33 -0500

Seen: 466 times

Last updated: Apr 20 '15