Ask Your Question
0

Neutron openvswitch agent goes to failed state

asked 2015-04-14 05:05:08 -0600

SudhirH gravatar image

updated 2015-04-15 01:58:39 -0600

dbaxps gravatar image

I have installed a 3 node Openstack cluster. (1 Controller + network and 2 compute node). Installation using packstack happened successfully. After rebooting the controller + network server node the neutron-openvswitch-agent went into failed state.

[root@rhel7vm1 ~]# openstack-status
== Nova services ==
openstack-nova-api:                     active
openstack-nova-cert:                    active
openstack-nova-compute:                 inactive  (disabled on boot)
openstack-nova-network:                 inactive  (disabled on boot)
openstack-nova-scheduler:               active
openstack-nova-conductor:               active
== Glance services ==
openstack-glance-api:                   active
openstack-glance-registry:              active
== Keystone service ==
openstack-keystone:                     active
== Horizon service ==
openstack-dashboard:                    active
== neutron services ==
neutron-server:                         active
neutron-dhcp-agent:                     active
neutron-l3-agent:                       active
neutron-metadata-agent:                 active
neutron-lbaas-agent:                    inactive  (disabled on boot)
neutron-openvswitch-agent:              failed
== Swift services ==
openstack-swift-proxy:                  active
openstack-swift-account:                active
openstack-swift-container:              active
openstack-swift-object:                 active
== Cinder services ==
openstack-cinder-api:                   active
openstack-cinder-scheduler:             active
openstack-cinder-volume:                active
openstack-cinder-backup:                active
== Ceilometer services ==
openstack-ceilometer-api:               active
openstack-ceilometer-central:           active
openstack-ceilometer-compute:           inactive  (disabled on boot)
openstack-ceilometer-collector:         active
openstack-ceilometer-alarm-notifier:    active
openstack-ceilometer-alarm-evaluator:   active
openstack-ceilometer-notification:      active
== Support services ==
libvirtd:                               active
openvswitch:                            active
dbus:                                   active
target:                                 active
rabbitmq-server:                        active
memcached:                              active
== Keystone users ==
Warning keystonerc not sourced

I have lost my public connectivity.

openvswitch log

2015-04-14 20:58:34.230 3939 TRACE neutron.plugins.openvswitch.agent.ovs_neutron_agent
2015-04-14 20:58:34.266 3939 WARNING neutron.openstack.common.loopingcall [-] task run outlasted interval by 76.23365 sec
2015-04-14 20:58:36.796 3939 ERROR neutron.agent.linux.utils [req-210f7bc0-6391-42c5-a65e-a9f657ebe9ed None]
Command: ['sudo', 'neutron-rootwrap', '/etc/neutron/rootwrap.conf', 'ovs-vsctl', '--timeout=10', 'add-port', 'br-tun', 'patch-int', '--', 'set', 'Interface', 'patch-int', 'type=patch', 'options:peer=patch-tun']
Exit code: 242
Stdout: ''
Stderr: '2015-04-14T15:28:36Z|00002|fatal_signal|WARN|terminating with signal 14 (Alarm clock)\n'
2015-04-14 20:58:36.796 3939 ERROR neutron.agent.linux.ovs_lib [req-210f7bc0-6391-42c5-a65e-a9f657ebe9ed None] Unable to execute ['ovs-vsctl', '--timeout=10', 'add-port', 'br-tun', 'patch-int', '--', 'set', 'Interface', 'patch-int', 'type=patch', 'options:peer=patch-tun']. Exception:
Command: ['sudo', 'neutron-rootwrap', '/etc/neutron/rootwrap.conf', 'ovs-vsctl', '--timeout=10', 'add-port', 'br-tun', 'patch-int', '--', 'set', 'Interface', 'patch-int', 'type=patch', 'options:peer=patch-tun']
Exit code: 242
Stdout: ''
Stderr: '2015-04-14T15:28:36Z|00002|fatal_signal|WARN|terminating with signal 14 (Alarm clock)\n'
2015-04-14 20:58:36.912 3939 ERROR neutron.plugins.openvswitch.agent.ovs_neutron_agent [req-210f7bc0-6391-42c5-a65e-a9f657ebe9ed None] Failed to create OVS patch port. Cannot have tunneling enabled on this agent, since this version of OVS does not support tunnels or patch ports. Agent terminated!
2015-04-14 20:58:36.979 3939 ERROR neutron.agent.linux.utils [req-210f7bc0-6391-42c5-a65e-a9f657ebe9ed None]
Command: ['ps', '--ppid', '5492', '-o', 'pid=']
Exit code: 1
Stdout: ''
Stderr: '
edit retag flag offensive close merge delete

Comments

What OS are you running on ? Is OVS version 2.1.3 ?

andrew.shvartz gravatar imageandrew.shvartz ( 2015-04-15 01:13:06 -0600 )edit

[root@rhel7vm1 ~]# ovs-vswitchd -V ovs-vswitchd (Open vSwitch) 2.1.3 Compiled Oct 10 2014 21:29:33 OpenFlow versions 0x1:0x1 [root@rhel7vm1 ~]# uname -a Linux rhel7vm1 3.10.0-229.el7.x86_64 #1 SMP Thu Jan 29 18:37:38 EST 2015 x86_64 x86_64 x86_64 GNU/Linux [root@rhel7vm1 ~]# cat /etc/redhat-release

SudhirH gravatar imageSudhirH ( 2015-04-15 02:03:59 -0600 )edit

1 answer

Sort by ยป oldest newest most voted
1

answered 2015-04-15 02:08:56 -0600

dbaxps gravatar image

updated 2015-04-21 03:11:46 -0600

UPDATE as of 04/21/2015
View https://bugzilla.redhat.com/show_bug....

For now downloaded openvswitch-2.3.1-2.el7.src.rpm from
https://repos.fedorapeople.org/repos/openstack/openstack-juno/epel-7/
installed and did a local build , afterwards upgraded  OVS to 2.3.1

#yum install openvswitch-2.3.1-2.el7.centos.x86_64.rpm \
openvswitch-debuginfo-2.3.1-2.el7.centos.x86_64.rpm \
openvswitch-devel-2.3.1-2.el7.centos.x86_64.rpm \
openvswitch-test-2.3.1-2.el7.centos.noarch.rpm \
python-openvswitch-2.3.1-2.el7.centos.noarch.rpm

Rebooted nodes.

Controller && Network Node in Cluster ( normal behaviour after upgrade)

[root@junowks01 ~(keystone_admin)]# uname -a
Linux junowks01.localdomain 3.10.0-229.1.2.el7.x86_64 #1 SMP Fri Mar 27 03:04:26 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
[root@junowks01 ~(keystone_admin)]# ovs-vsctl show
6f9300d0-7dc1-4e40-9628-d2674760cd79
    Bridge br-int
        fail_mode: secure
        Port patch-tun
            Interface patch-tun
                type: patch
                options: {peer=patch-int}
        Port br-int
            Interface br-int
                type: internal
        Port "qr-9fb96858-db"
            tag: 1
            Interface "qr-9fb96858-db"
                type: internal
        Port "tapc58924cf-10"
            tag: 1
            Interface "tapc58924cf-10"
                type: internal
        Port int-br-ex
            Interface int-br-ex
                type: patch
                options: {peer=phy-br-ex}
    Bridge br-ex
        Port "qg-00d8f4c6-3b"
            Interface "qg-00d8f4c6-3b"
                type: internal
        Port phy-br-ex
            Interface phy-br-ex
                type: patch
                options: {peer=int-br-ex}
        Port br-ex
            Interface br-ex
                type: internal
        Port "eth0"
            Interface "eth0"
    Bridge br-tun
        Port br-tun
            Interface br-tun
                type: internal
        Port patch-int
            Interface patch-int
                type: patch
                options: {peer=patch-tun}
        Port "vxlan-c0a80089"
            Interface "vxlan-c0a80089"
                type: vxlan
                options: {df_default="true", in_key=flow, local_ip="192.168.0.127", out_key=flow, remote_ip="192.168.0.137"}
    ovs_version: "2.3.1"

END UPDATE

Please,view https://ask.openstack.org/en/question...

edit flag offensive delete link more

Comments

Solved by moving to fedora21.

SudhirH gravatar imageSudhirH ( 2015-04-16 06:41:14 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-04-14 05:05:08 -0600

Seen: 2,729 times

Last updated: Apr 21 '15