Ask Your Question
0

rabbitmq cannot start after change config file

asked 2015-04-14 01:30:34 -0600

Eric Ren gravatar image

rabbitmq runs well, but cannot start after I change its config file according to the official doc.

I install openstack on opensuse13.2, following this doc:

http://docs.openstack.org/juno/install-guide/install/zypper/content/index.html

When reaching at 'Messaging server' section of 'Chapter 2. Basic environment`':

http://docs.openstack.org/juno/install-guide/install/zypper/content/ch_basic_environment.html#basics-messaging-server

Right here,some quote of this doc:

    3. For RabbitMQ version 3.3.0 or newer, you must enable remote access for the guest account.

        Check the RabbitMQ version:

   A.     # rabbitmqctl status | grep rabbit
        Status of node 'rabbit@controller' ...
         {running_applications,[{rabbit,"RabbitMQ","3.4.2"},

   B.   If necessary, edit the /etc/rabbitmq/rabbitmq.config file and configure loopback_users to reference an empty list:

        [{rabbit, [{loopback_users, []}]}].
   C. Restart the message broker service:
    On openSUSE:

    # systemctl restart rabbitmq-server.service

And I proceed like this:

a. controller:~ # rabbitmqctl status | grep rabbit
Status of node rabbit@controller ...
 {running_applications,[{rabbit,"RabbitMQ","3.3.5"},

b.change config file:/etc/rabbitmq/rabbitmq.config,i.e. uncomment this line

%% {loopback_users, []},

c.controller:~ # systemctl start rabbitmq-server.service 
Job for rabbitmq-server.service failed. See "systemctl status rabbitmq-server.service" and "journalctl -xn" for details.

d.controller:~ # systemctl status rabbitmq-server.service
rabbitmq-server.service - RabbitMQ broker
   Loaded: loaded (/usr/lib/systemd/system/rabbitmq-server.service; enabled)
   Active: failed (Result: exit-code) since 二 2015-04-14 14:27:59 CST; 30s ago
  Process: 7387 ExecStopPost=/usr/bin/rm /var/run/rabbitmq/pid (code=exited, status=0/SUCCESS)
  Process: 7345 ExecStop=/usr/sbin/rabbitmqctl stop (code=exited, status=2)
  Process: 7219 ExecStartPost=/usr/sbin/rabbitmqctl wait /var/run/rabbitmq/pid (code=exited, status=2)
  Process: 7218 ExecStart=/usr/sbin/rabbitmq-server (code=exited, status=1/FAILURE)
 Main PID: 7218 (code=exited, status=1/FAILURE)

4月 14 14:27:59 controller rabbitmqctl[7345]: attempted to contact: [rabbit@controller]
4月 14 14:27:59 controller rabbitmqctl[7345]: rabbit@controller:
4月 14 14:27:59 controller rabbitmqctl[7345]: * connected to epmd (port 4369) on controller
4月 14 14:27:59 controller rabbitmqctl[7345]: * epmd reports: node 'rabbit' not running at all
4月 14 14:27:59 controller rabbitmqctl[7345]: no other nodes on controller
4月 14 14:27:59 controller rabbitmqctl[7345]: * suggestion: start the node
4月 14 14:27:59 controller rabbitmqctl[7345]: current node details:
4月 14 14:27:59 controller rabbitmqctl[7345]: - node name: rabbitmqctl7354@controller
4月 14 14:27:59 controller rabbitmqctl[7345]: - home dir: /var/lib/rabbitmq
4月 14 14:27:59 controller rabbitmqctl[7345]: - cookie hash: kBnKPRMCXBnfQlB8kipSdA==
edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted
1

answered 2015-04-14 20:55:22 -0600

Eric Ren gravatar image

this is the right answer, which I verified.

the comma after {loopback_users, []}, should be removed if it the latest statement in config array (it is, if you editing original config that shipped with RabbitMQ distro).

edit flag offensive delete link more

Comments

thanks for sharing.

SGPJ gravatar imageSGPJ ( 2015-04-22 03:39:57 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-04-14 01:30:34 -0600

Seen: 2,796 times

Last updated: Apr 14 '15