Ask Your Question
0

Devstack build Compute Node , the ./stack.sh ignore the Neutron setup

asked 2015-04-13 13:49:36 -0500

DelightD gravatar image

updated 2015-04-13 13:52:52 -0500

I am using this link to build my environment

http://networkstatic.net/updated-devstack-opendaylight-vm-image-for-openstack-icehouse/?hc_location=ufi

The little different is I am using 3 entity computer(not VM build this lab) , ODL using karaf and openstack controller setup well without problem. but when I setup my compute node , I am sure that I enable the neutron service on compute node local.conf here is my compute node local.conf:

ODL IP:192.168.5.23

OpenStack Controller IP & Hostname: 192.168.5.203 & openstack

OpenStack Compute IP & Hostname: 192.168.5.83 & compute

[[local|localrc]]
LOGFILE=stack.sh.log
LOG_COLOR=True
SCREEN_LOGDIR=/opt/stack/data/log
RECLONE=yes

disable_all_services
enable_service nova n-cpu neutron n-novnc rabbit 
enable_service odl-compute

HOST_NAME=compute
HOST_IP=192.168.5.83
SERVICE_HOST_NAME=openstack   #controller hostname
SERVICE_HOST=192.168.5.203
VNCSERVER_PROXYCLIENT_ADDRESS=192.168.5.83
VNCSERVER_LISTEN=0.0.0.0

Q_PLUGIN=ml2
ODL_MGR_IP=192.168.5.23
Q_ML2_PLUGIN_MECHANISM_DRIVERS=opendaylight,logger
ENABLE_TENANT_TUNNELS=True
Q_HOST=$SERVICE_HOST

MYSQL_HOST=$SERVICE_HOST
RABBIT_HOST=$SERVICE_HOST
GLANCE_HOSTPORT=$SERVICE_HOST:9292
KEYSTONE_AUTH_HOST=$SERVICE_HOST
KEYSTONE_SERVICE_HOST=$SERVICE_HOST

MYSQL_PASSWORD=jizzbear
RABBIT_PASSWORD=jizzbear
SERVICE_TOKEN=service
SERVICE_PASSWORD=admin
ADMIN_PASSWORD=admin

[[post-config|/etc/neutron/plugins/ml2/ml2_conf.ini]]
[agent]
minimize_polling=True

[ml2_odl]
url=http://192.168.5.23:8080/controller/nb/v2/neutron
username=admin
password=admin

looking good so far, then ./stack.sh , it will setup successful and print the Compute node IP but it is wrong here , below is the " sudo ovs-vsctl show":

compute@compute:/var/log$ sudo ovs-vsctl show
648b2c72-f78d-4d03-8c47-ff39b257cc89
    Manager "tcp:192.168.5.23:6640"
        is_connected: true
    ovs_version: "2.0.2"

it miss the br-int , here is my /opt/stack , it without neutron and below /etc without neutron too:

compute@compute:/opt/stack$ ls
data  logs  nova  noVNC  requirements  status
compute@compute:/opt/stack$

Does anyone meet this problem before? Please help me , it show nothing error , but fail to setup correctly. thanks for reading my problem.

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2015-04-13 16:02:19 -0500

Is this a minimal install of neutron normally you need a few more enabled services for all the bells and whistles of neutron https://wiki.openstack.org/wiki/Neutr...

Have you tried this devstack guide? https://wiki.opendaylight.org/view/OV...

edit flag offensive delete link more

Comments

hi omar, I have seen the first wiki before , but my ovs is controlled by OpenDaylight OVSDB,so I think my openstack don't need q-agt , last time I add q-agt in my environment it will create and delete path-tunnel port infinite , so I rebuild this environment.

DelightD gravatar imageDelightD ( 2015-04-13 20:43:37 -0500 )edit

The Second link I saw before too, but that wiki local.conf github's link is dead , I can't get them. thank you for answer me :).

DelightD gravatar imageDelightD ( 2015-04-13 20:45:59 -0500 )edit
0

answered 2015-04-13 17:32:20 -0500

sripriya gravatar image

updated 2015-04-14 13:17:13 -0500

Try running the below commands.

sudo ovs-vsctl del-manager

sudo ovs-vsctl set-manager tcp:<controller_ip>:6640

Then do sudo ovs-vsctl show to see if br-int is created.

You also want to run the following commands on the compute node:

OVSUUID=$(ovs-vsctl get Open_vSwitch . _uuid)

ovs-vsctl set Open_vSwitch $OVSUUID other_config:local_ip=<host_ip>

edit flag offensive delete link more

Comments

Hi sripriya, nothing change , I think it miss neutron so it will fail , I am confused at I am sure that I already enable the service neutron but the ./stack.sh script ignore it , thank you for answer me :)

DelightD gravatar imageDelightD ( 2015-04-13 20:50:39 -0500 )edit

Even though you have neutron running on compute, You won't see neutron services in compute node because the neutron services runs on the controller node and there is only one network node for your setup. I have edited the above answer. Try running the last two commands along with the first two.

sripriya gravatar imagesripriya ( 2015-04-14 13:14:07 -0500 )edit

OVSUUID=$(ovs-vsctl get Open_vSwitch . _uuid)

ovs-vsctl set Open_vSwitch $OVSUUID other_config:local_ip=<host_ip>

I don't understand this two command, can you teach me in detail? thank you very much :)

DelightD gravatar imageDelightD ( 2015-04-14 20:35:03 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-04-13 13:49:36 -0500

Seen: 597 times

Last updated: Apr 14 '15