Ask Your Question
0

Swift and s3ql problem

asked 2015-04-13 06:56:51 -0500

shanecentre gravatar image

I'm new to swift and I believe I have a configuration issue. I'm trying to use s3ql with a swift installed fallowing the latest instructions for Ubuntu 14.04. Everything is up and running and I can use the swift cli stat the system as the user I want to connect as. I've created a container and uploaded/downloaded and deleted files from it using the cli. but when I try to use s3ql to make the files system:

mkfs.s3ql --debug --plain --authfile /root/.s3ql/authinfo2-test --backend-options no-ssl swiftks://10.4.1.21:5000/regionOne:s3ql Enter backend login: Enter backend passphrase: 2015-04-10 15:22:49.425 23265 MainThread s3ql.backends.common.get_ssl_context: Reading default CA certificates. 2015-04-10 15:22:49.426 23265 MainThread s3ql.backends.swift._do_request: started with 'GET', '/', None, {'limit': 1}, None, None 2015-04-10 15:22:49.426 23265 MainThread s3ql.backends.swift._do_request: no active connection, calling _get_conn() 2015-04-10 15:22:49.426 23265 MainThread s3ql.backends.swiftks._get_conn: started 2015-04-10 15:22:49.466 23265 MainThread root.excepthook: No accessible object storage service found in region regionOne (available regions: )

Its as if it doesn't see the regions. I've done this same think with a trial of SwiftStack and it works without issue so it has to be something with my setup.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2017-06-06 07:47:43 -0500

sherv gravatar image

updated 2017-06-06 07:49:10 -0500

I know this is, like, 2 years old, but if someone googles it in search of solution for a similar problem, like I did, you should try specifying project name with login name, like this <project name>:<user name>. The reason behind it that s3ql uses only username and password with keystone authentication, which leads to unscoped authentication, which doesn't return any catalog endpoints. To get a scoped authentication(which returns list of endpoints) you should specify a project(tenant) name. While official s3ql manual doesn't say it, you can find in code(/usr/lib/s3ql/s3ql/backends/swiftks.py for Ubuntu 16.04, apt installation) that project name and user name can be provided together, separated by colon.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2015-04-13 06:56:51 -0500

Seen: 333 times

Last updated: Jun 06 '17