Ask Your Question
0

Neutron with existing external network

asked 2015-04-12 15:21:49 -0500

tl gravatar image

updated 2015-04-15 04:02:17 -0500

Attempting to follow https://www.rdoproject.org/Neutron_with_existing_external_network (https://www.rdoproject.org/Neutron_wi...)

Where it says...

Add to the /etc/neutron/plugin.ini file these lines:
network_vlan_ranges = physnet1
bridge_mappings = physnet1:br-ex

...it's not clear where to add them. Do I just stick them in at the top of the file?

To clarify, as the tag says, I'm using Icehouse.

edit retag flag offensive close merge delete

Comments

Not to diminish the importance of ambiguity in the introductory documentation to the RDO Project, but I'm not entirely sure that it actually makes any difference where these lines go - or, indeed, if you omit them entirely.

tl gravatar imagetl ( 2015-04-14 08:47:34 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
1

answered 2015-04-14 11:43:56 -0500

dbaxps gravatar image

updated 2015-04-15 04:39:53 -0500

UPDATE 04/15/2015
Regarding IceHouse Multinode Deployment for Fedora 20 , please , view :-
http://bderzhavets.blogspot.com/2014/...
In particular, /etc/neutron/plugin.ini

[OVS]
network_vlan_ranges=physnet1:100:200
tenant_network_type=vlan
enable_tunneling=False
integration_bridge=br-int
bridge_mappings=physnet1:br-p4p1
[AGENT]
polling_interval=2
[SECURITYGROUP]
firewall_driver=neutron.agent.linux.iptables_firewall.OVSHybridIptablesFirewallDriver

END UPDATE

You are using outdated howto. RDO Juno AIO ( packstack --allinone ) will setup ML2&OVS&VXLAN configuration. When done remove router1 && public network , afterwards create public network via Horizon or CLI as you need ( in Horizon select type VXLAN , Segmentation 1005). Next step update ifcfg-br-ex and ifcfg-em1 ( say em1) files Interface name is provided by ifconfig. View http://bderzhavets.blogspot.com/2014/...
Stop&&Disable NetworkManager, Start&&Enable service network. /etc/neutron/ml2_conf.ini will be automatically created for you. Don't warry about this lines

edit flag offensive delete link more

Comments

1

Outdated howto? It's from the Quickstart page! I'm using Icehouse (edited question to clarify).

tl gravatar imagetl ( 2015-04-15 04:01:24 -0500 )edit

OK. See at https://www.rdoproject.org/Neutron_wi...
These instructions have been tested on a RHEL 6.4 "minimal" install VM attached to the default libvirt network. Make sure all of your repos are set up first:

dbaxps gravatar imagedbaxps ( 2015-04-15 04:10:17 -0500 )edit

As far as I know 6.4 is now unsupported in regards of RDO installs. 6.4 required special kernel patch to support namespaces.

dbaxps gravatar imagedbaxps ( 2015-04-15 04:14:09 -0500 )edit

Just, clarify are you doing AIO RDO IceHouse install or Multi Node Deployment ?

dbaxps gravatar imagedbaxps ( 2015-04-15 04:19:33 -0500 )edit
0

answered 2015-04-14 07:34:37 -0500

jdexter gravatar image

The following lines:

network_vlan_ranges = physnet1
bridge_mappings = physnet1:br-ex

Should go after [ovs] that is all that is required.

Als makes sure that you have br-ex created in OVS before you restart the openvswitch-agent.

edit flag offensive delete link more

Comments

My plugin.ini doesn't have an [ovs] section.

I'm running Icehouse. I think these instructions were written for Icehouse based on my memory of having used them before plus the reference to CentOS6.4 and NBs for CentOS7.

tl gravatar imagetl ( 2015-04-14 08:45:33 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-04-12 15:21:49 -0500

Seen: 275 times

Last updated: Apr 15 '15