Ask Your Question
0

devstack build error

asked 2015-04-10 06:37:21 -0500

praveens gravatar image

updated 2015-04-10 06:52:43 -0500

while building devstack in ubuntu 14.04 lts for juno stable release I am getting this error . please provide me the solution.

I tried with ./clean.sh also

  • install_keystone

2015-04-10 00:07:07.110 | + is_service_enabled ldap

2015-04-10 00:07:07.124 | + return 1

2015-04-10 00:07:07.124 | + [[ sql = \m\e\m\c\a\c\h\e ]]

2015-04-10 00:07:07.124 | + git_clone git://git.openstack.org/openstack/keystone.git /opt/stack/keystone stable/juno

2015-04-10 00:07:07.124 | + local git_remote=git://git.openstack.org/openstack/keystone.git

2015-04-10 00:07:07.124 | + local git_dest=/opt/stack/keystone

2015-04-10 00:07:07.124 | + local git_ref=stable/juno

2015-04-10 00:07:07.125 | ++ pwd

2015-04-10 00:07:07.126 | + local orig_dir=/opt/stack/devstack

2015-04-10 00:07:07.126 | ++ trueorfalse False False

2015-04-10 00:07:07.148 | + RECLONE=False

2015-04-10 00:07:07.148 | + [[ False = \T\r\u\e ]]

2015-04-10 00:07:07.149 | + egrep -q '^refs'

2015-04-10 00:07:07.149 | + echo stable/juno

2015-04-10 00:07:07.156 | + [[ ! -d /opt/stack/keystone ]]

2015-04-10 00:07:07.157 | + [[ False = \T\r\u\e ]]

2015-04-10 00:07:07.158 | + cd /opt/stack/keystone

2015-04-10 00:07:07.158 | + head -1

2015-04-10 00:07:07.158 | + git show --oneline

2015-04-10 00:07:08.256 | 410ade1 Merge "fix the wrong update logic of catalog kvs driver" into stable/juno

2015-04-10 00:07:08.258 | + cd /opt/stack/devstack

2015-04-10 00:07:08.258 | + setup_develop /opt/stack/keystone

2015-04-10 00:07:08.258 | + local project_dir=/opt/stack/keystone

2015-04-10 00:07:08.258 | + setup_package_with_req_sync /opt/stack/keystone -e

2015-04-10 00:07:08.259 | + local project_dir=/opt/stack/keystone

2015-04-10 00:07:08.259 | + local flags=-e

2015-04-10 00:07:08.260 | ++ cd /opt/stack/keystone

2015-04-10 00:07:08.260 | ++ git diff --exit-code

2015-04-10 00:07:10.820 | + local update_requirements=

2015-04-10 00:07:10.820 | + [[ '' != \c\h\a\n\g\e\d ]]

2015-04-10 00:07:10.820 | + cd /opt/stack/requirements

2015-04-10 00:07:10.821 | + python update.py /opt/stack/keystone

2015-04-10 00:07:11.536 | Traceback (most recent call last):

2015-04-10 00:07:11.537 | File "update.py", line 226, in <module>

2015-04-10 00:07:11.537 | main(options, args)

2015-04-10 00:07:11.537 | File "update.py", line 217, in main

2015-04-10 00:07:11.538 | _copy_requires(options.suffix, args[0])

2015-04-10 00:07:11.538 | File "update.py", line 179, in _copy_requires

2015-04-10 00:07:11.538 | source_reqs = _parse_reqs('global-requirements.txt')

2015-04-10 00:07:11.538 | File "update.py", line 118, in _parse_reqs

2015-04-10 00:07:11.538 | reqs[_parse_pip(pip)] = pip

2015-04-10 00:07:11.538 | File "update.py", line 85, in _parse_pip

2015-04-10 00:07:11.538 | elif install_require.url:

2015-04-10 00:07:11.539 | File "/usr/local/lib/python2.7/dist-packages/pip/req/req_install.py", line 128, in url

2015-04-10 00:07:11.680 | return self.link.url

2015-04-10 00:07:11.681 | AttributeError: 'NoneType' object has no attribute 'url'

2015-04-10 00:07:11.765 | + exit_trap ... (more)

edit retag flag offensive close merge delete

Comments

I have faced the same error (AttributeError: 'NoneType' object has no attribute 'url') a few days ago, I solved it reinstalling the OS, because I ran devstack in the same OS many times. If you reinstall don't forget to copy your localrc.

Eduardo Gonzalez gravatar imageEduardo Gonzalez ( 2015-04-10 06:52:16 -0500 )edit
1

Problem is fixed...I removed /opt/stack/requirements folder and run stack.sh once again.

praveens gravatar imagepraveens ( 2015-04-12 04:39:49 -0500 )edit

Convert to an answer your comment and mark as resolved to help other people please

Eduardo Gonzalez gravatar imageEduardo Gonzalez ( 2015-04-13 01:36:16 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
5

answered 2015-04-13 06:31:31 -0500

praveens gravatar image

Problem is fixed...I removed /opt/stack/requirements folder and run stack.sh once again.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-04-10 06:37:21 -0500

Seen: 1,026 times

Last updated: Apr 13 '15