Ask Your Question

VM Internet not working unless MTU is 576

asked 2015-04-09 22:14:25 -0500

ethode gravatar image

updated 2015-04-10 07:02:14 -0500

I am running Openstack juno ontop of Ubuntu 14.04

I am working with a VM using Ubuntu 14.04 as well - I've been struggling to figure out why I can ping but I could do a wget on it's logo just to test outside internet connectivity from a Ubuntu (14.04) server VM ...

I finally ran across a great post and I wound up changing eth0 MTU to 576 and then it appears things are happy.

I have all NIC cards in my Openstack cluster (1gb cards) connected to nice Gb switches and router, I can't imagine why i would be forced to set the MTU to such a low packet size aside from possible some issue with neutron or the L3 agent but at this point I've got nothing

While testing I did figure out that 1454 also worked for me. The default 1500 didn't however for some reason.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted

answered 2015-04-10 08:34:46 -0500

jdexter gravatar image

If you are using vxlan or gre, the tunneling requires overhead. This results in a larger packet size. If your VM is running with an MTU of 1500, when you use vxlan tunnels, then your packets that are running through the tunnel are actually 1542 (depending on gre or vxlan) There are a lot of good write ups about vxlan tunneling.

It is possible to have the dhcp agent set the mtu lower via the dhcp lease automatically.

edit flag offensive delete link more


Thanks for the explanation. I am indeed using GRE right now.

ethode gravatar imageethode ( 2015-04-10 13:04:32 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2015-04-09 22:14:25 -0500

Seen: 262 times

Last updated: Apr 10 '15