Ask Your Question
1

start failure of openstack-nova-compute.service on the compute node

asked 2015-04-08 07:58:47 -0600

brahimo gravatar image

Hi everyone,
i follow the steps given by the official documentation of the Openstack Juno release, i am using fedora 20. everything is ok until the step of starting the openstack-nova-compute.service in the compute node it takes time to start then it fails. this question is already asked but i didn't found any appropriate answer for my case.

with this systemctl start openstack-nova-compute.service, i got :

Job for openstack-nova-compute.service failed. See 'systemctl status openstack-nova-compute.service' and 'journalctl -xn' for details.


here is the output of journalctl -xn.

-- Logs begin at Thu 2015-04-02 17:13:31 CEST, end at Wed 2015-04-08 11:49:46 CE
Apr 08 11:48:16 localhost.localdomain systemd[1]: Unit openstack-nova-compute.se
Apr 08 11:48:16 localhost.localdomain systemd[1]: openstack-nova-compute.service
Apr 08 11:48:16 localhost.localdomain systemd[1]: Stopping OpenStack Nova Comput
-- Subject: Unit openstack-nova-compute.service has begun shutting down
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit openstack-nova-compute.service has begun shutting down.
Apr 08 11:48:16 localhost.localdomain systemd[1]: Starting OpenStack Nova Comput
-- Subject: Unit openstack-nova-compute.service has begun with start-up
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit openstack-nova-compute.service has begun starting up.
Apr 08 11:49:46 localhost.localdomain systemd[1]: openstack-nova-compute.service
Apr 08 11:49:46 localhost.localdomain systemd[1]: Failed to start OpenStack Nova
-- Subject: Unit openstack-nova-compute.service has failed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit openstack-nova-compute.service has failed.
--
-- The result is failed.
Apr 08 11:49:46 localhost.localdomain systemd[1]: Unit openstack-nova-compute.se
Apr 08 11:49:46 localhost.localdomain systemd[1]: openstack-nova-compute.service
Apr 08 11:49:46 localhost.localdomain systemd[1]: Stopping OpenStack Nova Comput
-- Subject: Unit openstack-nova-compute.service has begun shutting down
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit openstack-nova-compute.service has begun shutting down.
Apr 08 11:49:46 localhost.localdomain systemd[1]: Starting OpenStack Nova Comput
-- Subject: Unit openstack-nova-compute.service has begun with start-up
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit openstack-nova-compute.service has begun starting up.


and the status of the service gives.

[root@localhost ~]# systemctl status openstack-nova-compute.service -l
openstack-nova-compute.service - OpenStack Nova Compute Server
   Loaded: loaded (/usr/lib/systemd/system/openstack-nova-compute.service; enabled)
   Active: activating (start) since Wed 2015-04-08 11:54:17 CEST; 15s ago
 Main PID: 3980 (nova-compute)
   CGroup: /system.slice/openstack-nova-compute.service
           └─3980 /usr/bin/python /usr/bin/nova-compute

Apr 08 11:54:17 localhost.localdomain systemd[1]: Starting OpenStack Nova Compute Server...


in the controller node everything (rabbitmq, keystone, nova) works well.
the log of nova on the compute node shows this.

2015-04-08 14:50:03.152 2092 ERROR oslo.messaging._drivers.impl_rabbit [req-8af63ea0-2f93-4982-ac74-6ce2f5bd8658 ] AMQP server on controller:5672 is unreachable: [Errno 113] EHOSTUNREACH. Trying again in 5 seconds.
2015-04-08 14:50:08.155 2092 INFO oslo.messaging._drivers.impl_rabbit [req-8af63ea0-2f93-4982-ac74-6ce2f5bd8658 ] Delaying reconnect for 1.0 seconds...
2015-04-08 14:50:09.157 2092 INFO oslo.messaging ...
(more)
edit retag flag offensive close merge delete

3 answers

Sort by » oldest newest most voted
0

answered 2015-09-17 12:37:03 -0600

amirali gravatar image

i had same problem with ubunto server i spent 2weeks and finally it solved i did these changes remove rabbitmq and upgrade it to version 3.5.4 use default credential for accessing to rabitmq (user:guest and pass:guest) i mean drop keystone database and follow up steps again for creating tenants and users and roles

edit flag offensive delete link more
0

answered 2015-04-08 08:06:17 -0600

dbaxps gravatar image

updated 2015-04-08 08:13:19 -0600

Either AMQP brocker is not running or port 5672 is not open on Controller ?
Just check connectivity between controller && compute (TCP, ICMP).

 Regarding RDO Juno support on F20 was dropped.  Works fine on Fedora 21
edit flag offensive delete link more
0

answered 2015-04-08 08:53:54 -0600

brahimo gravatar image

here are further infos
the status of RabbitMQ server.

systemctl status rabbitmq-server.service -l
rabbitmq-server.service - RabbitMQ broker
   Loaded: loaded (/usr/lib/systemd/system/rabbitmq-server.service; enabled)
   Active: active (running) since Wed 2015-04-08 13:47:55 CEST; 2h 3min ago
 Main PID: 747 (beam)
   CGroup: /system.slice/rabbitmq-server.service
           ├─ 747 /usr/lib64/erlang/erts-5.10.4/bin/beam -W w -K true -A30 -P 1048576 -- -root /usr/lib64/erlang -progname erl -- -home /var/lib/rabbitmq -- -pa /usr/lib/rabbitmq/lib/rabbitmq_server-3.1.5/sbin/../ebin -noshell -noinput -s rabbit boot -sname rabbit@localhost -boot start_sasl -kernel inet_default_connect_options [{nodelay,true}] -sasl errlog_type error -sasl sasl_error_logger false -rabbit error_logger {file,"/var/log/rabbitmq/rabbit@localhost.log"} -rabbit sasl_error_logger {file,"/var/log/rabbitmq/rabbit@localhost-sasl.log"} -rabbit enabled_plugins_file "/etc/rabbitmq/enabled_plugins" -rabbit plugins_dir "/usr/lib/rabbitmq/lib/rabbitmq_server-3.1.5/sbin/../plugins" -rabbit plugins_expand_dir "/var/lib/rabbitmq/mnesia/rabbit@localhost-plugins-expand" -os_mon start_cpu_sup false -os_mon start_disksup false -os_mon start_memsup false -mnesia dir "/var/lib/rabbitmq/mnesia/rabbit@localhost"
           ├─1018 /usr/lib64/erlang/erts-5.10.4/bin/epmd -daemon
           ├─1864 inet_gethost 4
           └─1865 inet_gethost 4

Apr 08 13:47:34 localhost.localdomain systemd[1]: rabbitmq-server.service: Got notification message from PID 1018, but reception only permitted for PID 747
Apr 08 13:47:39 localhost.localdomain systemd[1]: rabbitmq-server.service: Got notification message from PID 1495, but reception only permitted for PID 747
Apr 08 13:47:54 localhost.localdomain rabbitmq-server[747]: RabbitMQ 3.1.5. Copyright (C) 2007-2013 GoPivotal, Inc.
Apr 08 13:47:54 localhost.localdomain rabbitmq-server[747]: ##  ##      Licensed under the MPL.  See http://www.rabbitmq.com/
Apr 08 13:47:54 localhost.localdomain rabbitmq-server[747]: ##  ##
Apr 08 13:47:54 localhost.localdomain rabbitmq-server[747]: ##########  Logs: /var/log/rabbitmq/rabbit@localhost.log
Apr 08 13:47:54 localhost.localdomain rabbitmq-server[747]: ######  ##        /var/log/rabbitmq/rabbit@localhost-sasl.log
Apr 08 13:47:54 localhost.localdomain rabbitmq-server[747]: ##########
Apr 08 13:47:55 localhost.localdomain systemd[1]: Started RabbitMQ broker.
Apr 08 13:47:55 localhost.localdomain rabbitmq-server[747]: Starting broker... completed with 0 plugins.
edit flag offensive delete link more

Comments

Please, run

netstat -lntp | grep 5672
iptables-save| grep 5672
dbaxps gravatar imagedbaxps ( 2015-04-08 10:53:43 -0600 )edit

Make sure your firewall , either firewalld or ipv4iptables firewall has port 5672 open

dbaxps gravatar imagedbaxps ( 2015-04-08 11:02:06 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-04-08 07:58:47 -0600

Seen: 7,408 times

Last updated: Sep 17 '15