facing a dns issue in nova networking

asked 2015-04-07 12:37:53 -0500

Prateek Arora gravatar image

Hi I setup openstack icehhouse on 5 machines using nova network with multi-host mode.

I am able to launch Virtual Machines successfully and Virtual Machines also getting ip address . Virtual Machines on same compute node talk to each other using dns name . but Virtual Machines on different compute node not able to talk to each other using dns but they can talk to each other using ip address.

network creation command : nova network-create demo-net --bridge br100 --multi-host T --fixed-range-v4 192.168.44.96/27 --bridge-interface eth1

current setup:

i am running four virtual machines , each on every compute node.

compute 1 : virtual machine name: master ip : 192.168.44.98

Entry in /var/lib/nova/networks/nova-br100.conf fa:16:3e:cc:f0:82,master.novalocal,192.168.44.98

compute 2 : virtual machine name: slave1 ip : 192.168.44.99 Entry in /var/lib/nova/networks/nova-br100.conf fa:16:3e:76:76:fc,slave1.novalocal,192.168.44.99

compute 3 : virtual machine name: slave2 ip : 192.168.44.100 Entry in /var/lib/nova/networks/nova-br100.conf fa:16:3e:7f:ce:f7,slave2.novalocal,192.168.44.100

compute 4 : virtual machine name: slave3 ip : 192.168.44.101 Entry in /var/lib/nova/networks/nova-br100.conf fa:16:3e:ec:da:f8,slave3.novalocal,192.168.44.101

1 machine : work as a controller ( keystone , glance , nova-api nova-cert nova-conductor nova-consoleauth nova-novncproxy nova-scheduler python-novaclient )

4 machines : works as compute node ( nova-compute , nova-network)

every machine have two Ethernet card ( eth0 and eth1).

eth0 use for external network ( corporate network) eth1 use for internal network.

controller eth1:192.168.44.11 compute1 eth1:192.168.44.31
compute2 eth1:192.168.44.32 compute3 eth1:192.168.44.33 compute4 eth1:192.168.44.34

controller node : ( nova.conf)

[DEFAULT] default_floating_pool = public network_api_class = nova.network.api.API security_group_api = nova dhcpbridge_flagfile=/etc/nova/nova.conf dhcpbridge=/usr/bin/nova-dhcpbridge logdir=/var/log/nova state_path=/var/lib/nova lock_path=/var/lock/nova force_dhcp_release=True iscsi_helper=tgtadm libvirt_use_virtio_for_bridges=True connection_type=libvirt root_helper=sudo nova-rootwrap /etc/nova/rootwrap.conf verbose=True ec2_private_dns_show_ip=True api_paste_config=/etc/nova/api-paste.ini volumes_path=/var/lib/nova/volumes enabled_apis=ec2,osapi_compute,metadata my_ip = 192.168.44.11 vncserver_listen = 192.168.44.11 vncserver_proxyclient_address = 192.168.44.11 rpc_backend = rabbit rabbit_host = controller rabbit_userid = openstack rabbit_password = f98d9fa7250b64ade8c0 auth_strategy = keystone

[keystone_authtoken] auth_uri = http://controller:5000 auth_host = controller auth_port = 35357 auth_protocol = http admin_tenant_name = service admin_user = nova admin_password = 8b0e8610e9f47c1dd0e2

[database] connection = mysql://nova:0d9fe7f7feb193fa0751@controller/nova

compute [1-4] ( nova.conf)

[DEFAULT] network_api_class = nova.network.api.API security_group_api = nova firewall_driver = nova.virt.libvirt.firewall.IptablesFirewallDriver network_manager = nova.network.manager.FlatDHCPManager network_size = 254 allow_same_net_traffic = True multi_host = True send_arp_for_ha = True share_dhcp_address = True force_dhcp_release = True flat_network_bridge = br100 default_floating_pool = public flat_interface = eth1 public_interface = eth0 dhcpbridge_flagfile=/etc/nova/nova.conf dhcpbridge=/usr/bin/nova-dhcpbridge logdir=/var/log/nova state_path=/var/lib/nova lock_path=/var/lock/nova force_dhcp_release=True iscsi_helper=tgtadm libvirt_use_virtio_for_bridges=True connection_type=libvirt root_helper=sudo nova-rootwrap /etc/nova/rootwrap.conf verbose=True ec2_private_dns_show_ip=True api_paste_config=/etc/nova ... (more)

edit retag flag offensive close merge delete

Comments

so you have a DNS server configured or you just added entries in your /etc/hosts file?

omar-munoz gravatar imageomar-munoz ( 2015-04-07 13:08:20 -0500 )edit

eth0 is connected to corporate network so dns is working here.

but all 5 machines also connected through eth1 using private network ( 192.168.44.11,192.168.44.31,192.168.44.32 etc). so no dns is running for eth1 . I just put entries in /etc/hosts

Prateek Arora gravatar imagePrateek Arora ( 2015-04-07 17:33:00 -0500 )edit

Hi Prateek,

Could you make a capture from the instance and try to follow the DNS request through Neutron ?

Charles Benon gravatar imageCharles Benon ( 2015-04-08 09:32:25 -0500 )edit