Creating bootable Cinder volume using volume-type

asked 2013-10-29 09:01:29 -0500

OldParrothead gravatar image

I am attempting to sort out where creation of volumes takes place in Cinder, and have had great success by using volume-types. This will allow us to aim smaller volumes at SSD drives, larger ones at NAS or SAN clusters. However, a decision was made (for some unexplained reason) to host running database images on Cinder volumes. This would include the entire structure, not just the database files.

So, I created a new volume-type, pointed it where I wanted it to be, and started there. When I create a volume, use that volume-type, no issues, creates the volume every time. If I try to add the --image-id argument to the create, one of two things happens. Not using volume-type, it fails with a disk space issue (WHICH IS FINE, because the default is to a very small area). If I use volume-type, I get an "error" condition, which when I look in the cinder-scheduler log gives me an error message as follows:

2013-10-29 09:41:51  WARNING [cinder.scheduler.filters.capacity_filter] Insufficient free space for volume creation (requested / avail): 50/2.0

The 2.0 GB is the space available on my default for Cinder. I know WHERE the information is coming from, but not why.

Here is Controller Cinder Config (Small disk area, runs cinder-api, cinder-scheduler, cinder-volume default) http://paste.openstack.org/show/50131/

Here is Cinder config from server running large disks http://paste.openstack.org/show/50132/

Cinder information:

root@amrwobl222:/var/log/cinder# cinder type-list
+--------------------------------------+--------------+
|                  ID                  |     Name     |
+--------------------------------------+--------------+
| 51271f02-cd45-49c9-b36e-ffd8cbef08c1 |  DB_Storage  |
| b9964907-97ec-4308-866b-043ccb7f4a19 |  Big_Disk2   |
| f6f9d846-299e-46d8-b10a-d3f84d86d526 | Bulk_Storage |
+--------------------------------------+--------------+
root@amrwobl222:/var/log/cinder# cinder extra-specs-list
+--------------------------------------+--------------+-----------------------------------------+
|                  ID                  |     Name     |               extra_specs               |
+--------------------------------------+--------------+-----------------------------------------+
| 51271f02-cd45-49c9-b36e-ffd8cbef08c1 |  DB_Storage  |  {u'volume_backend_name': u'LVM_iSCSI'} |
| b9964907-97ec-4308-866b-043ccb7f4a19 |  Big_Disk2   | {u'volume_backend_name': u'LVM_iSCSI2'} |
| f6f9d846-299e-46d8-b10a-d3f84d86d526 | Bulk_Storage |  {u'volume_backend_name': u'LVM_iSCSI'} |

+--------------------------------------+--------------+-----------------------------------------+

Am I missing something, or does one argument (--image-id) negate the other (--volume-type). BTW, I have tried the arguments in mutiple order, just in case, always the same error.

Thanks

edit retag flag offensive close merge delete

Comments

Storage availability zones do seem to be working (if I can get by some Glance issues..). But, it still doesn't explain why volume-type isn't.

OldParrothead gravatar imageOldParrothead ( 2013-10-30 09:29:05 -0500 )edit

volume-type and image-id are fine to use together, didn't see your cmd in the posting, should be something like "cinder create --image-id xxx --volume-type xxx $size". Let me know the cmd you're using. Also take a look at the scheduler and volume logs, see what they're reporting.

jgriffith gravatar imagejgriffith ( 2013-10-31 22:52:15 -0500 )edit