Ask Your Question
3

Search domain in resolv.conf not updating

asked 2015-04-02 13:22:32 -0500

Florin gravatar image

I have a private DNS server within one of my clouds. I launched this instance with a fixed IP, and then updated the subnet definition such that it points to the this DNS server. When I launch a new instance, the namserver option in the /etc/resolv.conf file is correct and points to the right IP address, however the search domain is always search openstacklocal localdomain.localdomain.

I could easily, manually change this, however I would like this to happen automatically when the instance boots up. Is there some sort of option where I could specific the search domain for each cloud? Or am I missing something entirely?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
2

answered 2015-04-03 03:35:56 -0500

How did you change the configuration?

You must change the dhcp_domain in dhcp_agent.ini file. See related page on Configuration Reference Guide

edit flag offensive delete link more

Comments

1

Having set dns_domain in /etc/neutron/neutron.conf (for mikata, that is apparently the place to set it) on each of 3 controllers, restarting neutron and creating a new instance "search openstacklocal" is still in it's /etc/resolv.conf.

S.Boran gravatar imageS.Boran ( 2017-03-24 09:16:20 -0500 )edit
1

Hmm, there are dnsmasq processes running, but they have an argument "--domain=openstacklocal", I wonder where that comes from? Ah, set dhcp_domain in /etc/neutron/dhcp_agent.ini and then do "service neutron-dhcp-agent restart", that does the trick!

S.Boran gravatar imageS.Boran ( 2017-03-24 09:16:24 -0500 )edit

Same thing happened for me, S. Boran. Tried changing dns_domain in neutron.conf, restarting neutron-dhcp-agent didn't change the --domain=openstacklocal argument to the dnsmasq process. Only when I changed dhcp_domain in dhcp_agent.ini and restarted again it works. Also running Mitaka.

timss gravatar imagetimss ( 2017-07-06 10:07:59 -0500 )edit

Same here, using Mitaka and dnsmasq process only are launched with --domain=mydomain when changed the dhcp_domain option in dhcp_agent.ini.

correajl gravatar imagecorreajl ( 2018-01-08 05:50:45 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-04-02 13:22:32 -0500

Seen: 4,171 times

Last updated: Apr 03 '15